Missing MenuBar and unwanted close-button

I created my first app for the raspberry pi, launched it an detected 2 problems:

  1. My app has 2 windows, both with the MainMenuBar assigned in the properties and menu bar is set to visible. In the debugger everything looks fine but on the Raspberry the menubar is missing.

  2. The “has close button”-property is set to false in the inspector. Again, running in the debugger there is no close button, but on the raspberry there is one and leads to a NIL-Exception when it gets pressed.

I tried a lot but don’t know how to fix it.

On desktop applications, when you add a new window, there is no MenuBar attached. It may be the same here.

If so, in the Right pane, in Properties mode, set the default one.

Thank you Emile. But I’m not sure if I got it right:
In the right pane (Inspector) there is a popup menu for menus. This is set to Main Menu Bar. At the next page there is a switch for deprecated and I set Menu Bar Visible to true. I’m not sure what else I should do.
In the debugger it works fine but not on the raspberry.

Compare your two windows and set Window2 to the same as Window1 for the MenuBar.

Sorry, I cannot help better.

Thanks a lot for trying to help, but unfortunately this didn’t solve the problem.

It must be something Raspi-specific. I tried it in the debugger with windows an on a mac without any problems. Only on the Raspberry the unwonted button appears an the menu disappears :frowning:

Did you checked code ? You may have added code to do that, forget and change your mind ?

Now, it also can be a bug (I do not know).

I solved the problem with the missing menu bar! It’s a stupid thing.
On Raspberry Pi the menu bar is at the upper part of the window without a striking background color. So I got black letters on dark background and I could not see it.

But I didn’t solve the second issue: The close button of the window is still active. Does anybody know how to get rid of it? The “has close button”-property is set to false in the inspector. But the close button still works.