MessageDialog and MsgBox not active window

MessageDialog and MsgBox not always active window. I think it should be even if the main window not active. For example when I drag and drop a file to my window.

On Windows? @anon20074439 knows a bit about this bug. I’ve just pinged him, so let’s see what he can tell us :slight_smile:

For sure on windows and as far as I remember on mac too. I’ll check out mac tomorrow.

Ya it’s bugged, happens in the ide too. Afk a bit so I can’t check feedback. I’ll come back here later.

1 Like

On macOS too… since the down of time :japanese_ogre:

It is one of teh reasons why I use System.DebugLog or I implement my own window (depend of the use).

OK, then an acceptable workaround could be set the window active before call MessageDialog/MsgBox.
Is that possible?

It might be, but I think Xojo does that and it doesn’t work in some cases as you sometimes end up with the window behind the IDE or other windows and you’re left wondering why you can’t click the IDE so I can’t say for certain without some testing. I can’t find anything about it in feedback, but that’s no surprise. If you do want to do it that way, search for BringWindowToTop on the forum and there should be some posts telling you how to use write the declare.

For MessageBox, there’s no way to set MB_SETFOREGROUND and/or MB_TOPMOST. As for MessageDialog, you can’t get a handle to it before it’s shown so it’s not trivial to step in and force it to the front. Unfortunately, the way to do it correctly would be to write your own.

what an annoying bug.!!!
I have a menu and an Exit option and it calls
messagedialog and it hides behind another window…
so no way exit the application…