"MenuItem does not exist", even though it does

So I am having a hard time with this.

I have the default MenuBar1 in my project. I am trying to access its menuitems and the project can’t compile. The error:

I did some research and found this thread in which Oliver was having the same issue I think, but his problem had something to do with the index (which he had set).

These are my properties for EditCut:

Autocomplete shows up EditCut and the other MenuItems, but it doesn’t compile.
I am using RS 2012 r2.1, and Windows 8

Thank you in advance.

Same error on Xojo 2013r2.

It may be due to the face that you are messing with OS operations (Cut/Paste/Copy) (in this case CUT) and you are making a CLONE (as clearly indicated by the error message)

That being said… OSX allows me to add handler code to the existing menu item… I have not extended that to see if it screws with the default behaviour… and can not see a valid reason to do so.

If you want to NOT use the system default behaviours… try changing the menu name to something else

Hmm I will try to rename the MenuItems, hopefully it will work. Thanks Dave.

BTW I didn’t mention it, but the code is actually part of CustomEditField, with 0 changes. I simply copy pasted it into my project, and it doesn’t compile.
When I copy pasted it into a brand new project, it works perfectly, so I guess it’s a bug.

Renaming the MenuItems doesn’t change a thing. Same error.

Again I ask… what are you trying to accomplish… perhaps there is a better way

Is your Menu Bar specified on App.MenuBar and the main window Menu Bar?

Specified it in App and it works! Thanks!