MBS ChartDirector can't find fonts on Web

Hey all,
I’m working with MBS ChartDirector to make some graphs on my Web App. I am using 2020R1 and the newest of the MBS plugins, but for some reason, once the app is on the Xojo Cloud ChartDirector can’t find the fonts, and all my labels are gone. I have tried redefining the search path, and I may be doing the paths wrong, but I put a folder with the font .ttfs in the root directory of the project, and I can;t seem to get them still. Any help would be appreciated!

This is on Xojo Cloud:

This is on the Run version:

Seems like you missed the note about fonts on Linux:

1 Like

No, I believe @CJ_Raymond has tackled the issue:

but I put a folder with the font .ttfs in the root directory of the project, and I can;t seem to get them still

But he is working with Xojo Cloud, where you can’t install anything yourself. Perhaps @Jason_Parsley can help here? Xojo Cloud might have changed meanwhile, but when I worked with it last time roughly a year ago it was not possible. On the other hand I’m quite confident that I made ChartDirector work at that time, but if I did, I can unfortunately not recall what I exactly did - probably I asked @Jason_Parsley :slight_smile:

1 Like

Have a look at the Installing Fonts section of the Xojo Cloud docs.


thank you @Anthony_G_Cyphers, well spotted and it rings a bell. @CJ_Raymond in Christian’s Link please note as well his hint on that page:

No backslash on the end of a path, please.

If your brain is working like mine, you will not memorize if you have to set the backslash or not. All I know is that I always need 2 tries :-).

1 Like

Thank you all for the quick responses! I’m taking a look at using sftp to upload the fonts to the Xojo Cloud, and I will update if it works.


You had it right, I installed the fonts using sftp and then in the session opening added the setFontPath for ChartDirector and then it worked flawlessly. Thank you for the help everyone!


Great news, and BTW good looking chart :wink: