[MAS] Call helper app via shell

Hello guys,
Is possible to call an helper app via shell? Will I have some troubles with MAS?


There’s a discussion about helper apps and sandbox here: https://forum.xojo.com/12479-helper-apps-and-the-sandbox

Thanks Albin, but is’t that thread about GUI helper apps (same bundle identifier troubles)? I need to call a console command that is in my bundle.

I think you’ll find it’s the same issue with GUI or console apps.

James in the other thread was using Xojo to create a graphical front end to scientific software that runs on the command line. So he was using console apps as helpers and had the some problems.

Sandboxing blocks shell the same way.

I tried calling a console app or a GUI app within the bundle through shell, and it was rejected as well. I even tried to copy the app to the temp or appData folders and attempted to launch it from there with .launch and with shell, same thing.

Direct calling a program within the bundle is rejected outright for security reasons.

Calling a program out of the program generates another error : the app could not be launched because the suer has not launched it manually before.

End result is the same.

Note that launching an app in the Applications folder that has been put there by the user works perfectly, though folderitem.launch or shell Open.