Mac local Apache debugging problem

Xojo web apps newbie question for a local Mac apache test run: Today I made the mistake of installing postgres and phpPgAdmin which also updated my Apache installation. As a result, my Xojo demo web project won’t run when launched from the debugger. My browser loads the address like it used to: But now that page is no longer the Xojo web app, but some front page nonsense text from EDB (where I got the postgre installer). Does anyone know what I messed up in the config files that will stop Xojo apps from debugging like this? Thanks in advance.

Did you tried to change debug port in Xojo… maybe from 8080 to 8082 ?

Interesting. That worked. Thanks! Still curious how to get it back to 8080, but this will suffice for now. Thanks again.

Probably your Apache installation took over the 8080 port. You should try to change that into the Apache config.
I personally use MAMP for local development and in the GUI i can set any port i want for the web server.

/etc/apache2/httpd.conf is the likely location for the changes that have bound to port 8080.

Traditionally, there’s a history of folks using 8080 as “test web server” - so it’s not surprising that more than one app may try to use it. There are plenty of ports in the sea, and there’s nothing surprising about 8080 so using 8082 is a fine solution.