Long delays when running Xojo from a domain workstation

I’ve noticed that if I install Xojo (any of the 2017’s and I think it was any of the 2016’s too) on a computer that is part of a Windows domain, when loading or compiling a project (big, small, Xojo Example, etc.) it gets about 1/2 way, then pauses a long time (one minute or more), then finishes. The debug app runs fine once it’s compiled, but when I exit the app, there is another long pause (one minute or more) before the IDE allows me to do anything again. Saving the project, or building the project is fast like it should be. This is consistent with any of my computers on the domain, including the server. Now, if I log in as a local user or as part of a Windows work-group (instead of the domain), and run Xojo, everything is fast and as it should be. Again, I’ve tried this on multiple computers on my network, and it’s consistent. I use Window Server 2012 R2 for domain server, file server, etc. My workstations are Windows 10 and Windows 8. I can submit a feedback report, but I want to see if anyone else is experiencing this or if it’s just something with my network configuration?

Is your user profile stored on the server?

Yes, we store the user profiles on the server. Our network is all 1 Gbps.

I’ve seen this behaviour with Word and Excel too.
My theory is that they somehow go awol while they evaluate all the available drives and mappings available on the network.
No network, no long pause.

Interesting. You are probably right. If I think about it, it probably is about the time that I put in new servers and went from a Windows work group to a domain network when I started noticing this. I’ve seen some delays with other apps too when accessing the hard drive - once in a great while though. Most of the time everything is very fast. Running any app within Xojo, delays every time.

On Monday or Tuesday, I’m going to try and set up a policy to allow me to store my profile locally. I’ll report the results.

Thanks for your input Carsten & Jeff.


it does seem to have to do with user profiles being stored on the server. I installed onto a computer on a similar Windows 2012 network where the user profiles are stored locally, and Xojo works normally including fast loads, fast debug compiling, etc. If anyone has an idea for a workaround for my computer on the Windows 2012 network where the user profiles are being stored on the server, I’d love to hear it. This is our main setup and my computer is set up this way. Woking in Xojo is so slow that I can’t use it when logged into the domain. The way I’m doing it now is I log into the domain, then switch users and log in locally. I run Xojo from the locally logged in user and switch to my domain user for the rest of my work (including email, etc.). There is a lot of switching back and forth throughout the day.

I would like to see that it is possible to set the “working” directory (for AutoSave, compiling etc.) in the Xojo preferences.

You’ll want to ensure that Offline Sync is not enabled for the folders your working with. For example if your app development folder is in your Documents folder, then it could be trying to sync upon every change/edit. Additionally make sure your temp folder is local to the machine.

If you have write permissions to your local hard disk I’d try running all dev from a subfolder there.

Thanks for your input Tanner. I’ve got offline sync completely off. Also, my temp folder is local. The folders that are on the server are my roaming folder, documents, and desktop. The group policies are set up to just point to these folders on the server. They are not copied between server/client. I’ve also tried having my Xojo data directory on my local drive so that my development app is loaded/built, etc. from my local drive. The long delays are still there.