Little issue with MBS examples

I have installed MBS Plugins because I was just curious and wanted to play a little bit with them.
After the installation on my MacMini M1 I have tried a few examples.
However, when I wanted to run the examples I always got compilation errors with messages like:

"Compilation of “Big Number Test” failed.
An error occurred when attempting to launch the application.

After looking into the issue I was able to find the reason for that behaviour.
It happened because in the Build Settings/This Computer the Architecture was set to X86-64bit instead of Universal.

I hope this topic can help others if facing the same strange error message when dealing with foreign source code. :blush:

The examples run fine for me on my M1 Air. The error message doesn’t have anything to do with the architecture. From where did you run the examples?

I have downloaded the MBS Plugins and copied the examples locally into my project folder.
It does make sense to me. After changing the Architecture to Universal all plugins work flawless.

Maybe you are using an older download.

Where is your project folder?

The age of the MBS download doesn’t matter.

Beatrix, even if I am doing a new test project without using plugins and I am changing the architecture to x86-64bit I get the same error message.

You don’t have Rosetta installed?

Right, I don’t have Rosetta installed else I would not get this error message I guess.

I wrote a feedback case: 65986

If you have no Rosetta and the Mac target is set to Intel CPU; it should switch to Apple Silicon for debug run.

3 Likes

Christian, thank you for writing the feedback case. This would become more serious with the time because once most important software is running native on Apple Silicone Rosetta2 will not be used that often anymore. Should be quite easy to fix, though. :blush:

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.