Linux Distribution

Hello,

Wish distribution do you recomand/use with Xojo on Mac M1 with parallel desktop? The last post on the forum was created on April 2014…

I use openSUSE Leap 15.3 and have also used Ubuntu 20.04 (and the KDE variant - Kubuntu). I tried elementaryOS but was sold on that (in itself rather than an issue with it and Xojo).

I also use Raspberry Pi OS on a Pi which is Debian and LXDE. The Xojo IDE is not supported on Pi though as it’s ARM, but you can create apps which run on a Pi with Xojo.

We use Ubuntu without much trouble. Prefer to run the .tgz from a termnial than using .deb install.

1 Like

I just download and install Ubuntu 20.04 on Parallels Desktop on Mac M1. I download Xojo from Xojo.com.

I put downloaded directory in application Folder but when I try to launch Xojo nothing append.

Any idea ?

The Xojo IDE requires and x86-64 bit processor. To do this, you’re going to need an emulator, assuming there’s even one available.

FWIW, I did a brief search and the only ones I’ve found are specifically for 32-bit games.

Thanks @Greg_O_Lone so there is no possibility to run Xojo IDE on Linux ARM (Debian or Ubuntu). Does Xojo plan to solved that?

As I said above, the only way would be to use an emulator (like Rosetta2 for M1 macOS).

That is correct. Unfortunately, Linux doesn’t have an x86_64 emulator (like qemu) for the ARM platform at this point.

1 Like

Today I install UTM from https://mac.getutm.app and follow ubuntu installation instruction here: Ubuntu 20.04 | UTM. Just set drive size to 250 Go (or less but 10Go is not enough)

Then I download Xojo for linux Ubuntu (.deb) and save it to my download folder

On the terminal (in download folder) type:

sudo dpkg --add-architecture amd64
sudo dpkg -i xojo2021r21.deb

Here is the terminal log

seb@monkeydev:~/Téléchargements$ sudo dpkg --add-architecture amd64
seb@monkeydev:~/Téléchargements$ sudo dpkg -i xojo2021r21.deb
Sélection du paquet xojo2021r2.1:amd64 précédemment désélectionné.
(Lecture de la base de données… 142920 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de xojo2021r21.deb …
Dépaquetage de xojo2021r2.1:amd64 (2021.02.1) …
dpkg: des problèmes de dépendances empêchent la configuration de xojo2021r2.1:amd64 :
xojo2021r2.1:amd64 dépend de libc6 (>= 2.15).
xojo2021r2.1:amd64 dépend de libglib2.0-0 (>= 2.32.4).
xojo2021r2.1:amd64 dépend de libgtk-3-0 (>= 3.4.1).
xojo2021r2.1:amd64 dépend de libunwind8.
xojo2021r2.1:amd64 dépend de libsoup2.4-1 (>= 1.0.0).
xojo2021r2.1:amd64 dépend de libwebkit2gtk-4.0-37 (>= 1.0.0) | libwebkit2gtk-3.0-25 (>= 1.0.0) | libwebkitgtk-3.0-0 (>= 1.0.0).

dpkg: erreur de traitement du paquet xojo2021r2.1:amd64 (–install) :
problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2) …
Traitement des actions différées (« triggers ») pour shared-mime-info (1.15-1) …
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1ubuntu1) …
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.24-1ubuntu3) …
Traitement des actions différées (« triggers ») pour mime-support (3.64ubuntu1) …
Des erreurs ont été rencontrées pendant l’exécution :
xojo2021r2.1:amd64
seb@monkeydev:~/Téléchargements$

Logs are in French but easy to understand.

When I try to launch Xojo, nothing happen :cry:

I think I’m not so far to the solution :thinking:

Try running it from the command line to see what prints out. If you’re using Wayland, you’ll want to switch to X11. Xojo has trouble with Wayland.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.