LInux app will not start

Trying to get an established Mac/Win project running on Mint 64bit
I click Run, stuff compiles.
Then nothing.
No errors, the App Open event doesnt fire… nothing happens at all.
Break on exceptions is set and produces nothing.
Unhandled exception is not triggered.

What might cause that?

Had a similar issue some time ago. I don’t know if your code invokes a ‘quit’ somewhere.
It did in my case. After ‘Quit’ nothing happened, even Unhandled exception did not seem to get triggered. Until I included code below in App.UnhandledException Event, this solved it for me.

If error IsA EndException Then
   Raise error
End If

Probably will not solve your issue, but maybe hint you to something?

I’ll check for ‘quit’, but literally not even the first line of App.open is being paused when in debug mode.
I have code in unhandled exception, and that isnt being paused in debug mode either.

ldd /path/to/app

In the terminal and you see if you miss libraries

Running the app from a console terminal sometimes exposes extra information:

  • Open a terminal and navigate to the app directory
  • ‘Run Paused’ from Xojo
  • Run the app in the window

So I cd to the folder where the Debug file is,
I type . /DebugMyApp

and I get DebugMyApp: is a Directory

ldd gives me DebugMyApp is not a regular file

Did you set the executable flag?

If I right click on it and choose properties, Mint shows it as program with the ‘allow executable’ tickbox ticked

Its a single file, with a gear cog icon, in a folder that also contains a folder for libs, extensions and resources, named for the app file.

Does it work when you push it over to the Remote Debugger? If so, then check what @DerkJ mentioned, make sure it’s be chmod’d to 755 to allow it to execute.

Remote Debugger?
I dont have one… where would I remote to/from?
I was expecting to press ‘Run’ in the Linux IDE and see it run on the Linux machine.

So I cd to the folder where the Debug file is,
I type . /DebugMyApp

and I get DebugMyApp: is a Directory

ldd gives me DebugMyApp is not a regular file

Almost there:
cd into DebugMyApp then type ./DebugMyApp

./DebugMyApp gets me NoSuch File for Directory
. DebugMyApp gets me ‘cannot execute binary file’
ls-l DebugMyApp gets me - rwxr-xr-x which to my newbie in Linux eye, looks pretty executable to me.

Oddly, the ‘debugging folder’ contains a folder named as if it was my app, a folder of libs, and a folder of resources. (Very like a Windows build)

CD into the ‘app that looks like a folder’ and once inside that, I find ANOTHER folder of resources, libs and extensions. (Very like a Mac bundle)
Why the duplication?

So, once again, I am finding that taking a mature project of some size from Mac to Linux, just fails. (I have tried porting to Linux every 5 years or so and never succeeded in getting a working app)

I can confirm that a ported trivial project which does very little, works in the same machine, same IDE

Might this be a memory problem?
Mint running in a VM with 8Gb RAM allowed.
(Although I thought Linux was much less hungry when it comes to memory requirements?)

In that directory, what is the result of this:
file DebugMyApp

file DebugMyApp DebugMyApp: ELF 64-bit LSB Executable, x86-64
version 1 (SYSV), dynamically linked, interpreter /lib64/l, for GNU/Linux 2.6.24 with debug info, not stripped

-rwxrwxr-x

uname -a

In terminal. Please provide the output here

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.