Hi all!

I’m using the VLC plugin from,
On windows all work perfectly,
but when i use it on Ubuntu, as soon as i launch the example Project [ShowVideoSample.rbp] present in the plugin’s download
a MsgBox shows the follow message:


/usr/lib/ :undefined symbol: libvlc_video_set_spu_delay

I’ve installed the last version present in the repository of vlc and that library is installed…

Have u any ideas?

Thanks a lot


Maybe version mismatch?
We may need an older version.

Or maybe the lib is there and 64bit?

Hi Christian,
i tried it with 1.0.6 and 2.0.5 version but the problem is ONLY on the 1.0.6

with the 2.0.5 all work perfectly, but the problem is i can use version 2.0.5 because this version is present in the newest release of Ubuntu,
i have to use Ubuntu 10.04LST and the last version of VLC i can have is 1.0.6.

Maybe u know if there is a way to install a new version of vlc on Ubuntu 10.04 LST?


Sorry, no idea. But plugin requires version 2.

Ah ok!

But there is an old plugin on

where the version required of vlc is < 2?


Sorry, I don’t think we have that.

OK :slight_smile:
Thanks for all Christian!

From VLC website:

Ubuntu includes whichever VLC version was the latest at the time the Ubuntu release was frozen (typically about two months before the official Ubuntu upgrade).
Afterward, you can still get security and critical bug fixes, but no further major VLC version updates until the next Ubuntu release.
If you need a more recent version, please consider upgrading Ubuntu.