Last Row of Section 0 in iosTable not visible until ...

I load an iosTable with with a common routine and based on some sort parameters it creates sections for the the DB column break on the sort.

Consistently on my iPhone the Last Row of the First Section (Section 0) is always blank but on the simulator it is populated with the correct contents. It does not matter how many rows are in Section 0 it is always the last one that is blank.

If I slide the row up and off of the view and back down the contents are repopulated (refreshed).

I added some code to the Method that populates the iosTable to capture the Last Row in Section 0 and do a ReloadRow after the complete table is loaded and it fixes the problem.

I tried to do a ReloadRow after every row was loaded but that did not work.


rowCount reply the same number for each section in simulator and iPhone?

I have not checked but I am pretty sure the rowCount would be the same in the iPhone and Simulator because it loads from the same SQLite DB.

My initial testing was simply to hard code what I knew to be the values of the last row in the section based on the sort then use the hard coded values for the ReloadRow and it worked. From there I did the dynamic calculation based on the sort selection since the data could possibly change in the future.

In the simulator I did NOT need the ReloadRow for it to work correctly. Only the iPhone had the problem.

I suppose I could verify that it is the same value in the iPhone and Simulator.