Keybounce (double pressing) causing issues

Dear All,

I have a Xojo Web app, deployed to Xojo Cloud which enters data in a SQlite database hosted on the same Cloud.

I have reliable reports that users can “double enter” data by pressing the “submit” button quickly.

I invalidate the submit button by doing this in the Action event:-
me.enabled = false
and then initiating the database entry methods

but the de-enabling evidently takes too long. Some users can reliably double enter if their network latency is excessive.

Are there any methods to prevent this ?

Regards,
Tony Barry
Sydney

The latency is in telling the page to not allow another click.
So instead of relying on that, how about set a boolean property at the session level ‘doing it now’
and also disable the button.

While that is set, any other attempt to do the same code will be ignored.
at the end of the database stuff, change the flag. Then enable the button.

Or use a timer to say ‘if this request is within 2 seconds of the last one, ignore it’

Thank you Jeff. The issue is described here:-

https://forum.xojo.com/37837-prevent-user-from-keep-clicking-on-submit-button-while-processi/0#p308587

in a post by Alvin Lin and answered by Greg O’Lone

There is a property of ordinary web buttons called “Auto-disable” which works to prevent such issues.

Regards,
Tony Barry

here is a property of ordinary web buttons called “Auto-disable”

Thats cool.
(I dont use the web edition personally)