Kaju Not updating after using Latest Xojo 2017R1.1 and Latest Windows 10 updates

Hello Kem,

I hope you are well.

Today i did another update on one of the windows software and all ok until the update part.

All goes smooth, it says that there is an update, i press Quit and install as usual and once it quits it dies there, no more Command prompt window, no more replacing files, no logs , nothing .

It`s hard to debug if i have no idea where to start.

So far if i look into the App Location folder it seems that it creates that decompressed folder but it does not move the files around and relaunch the app .

I just did the latest updates on windows 10, i even stopped the antivirus as well and still nothing happens.

If i open the app from the decompressed folder it works well so there is no data corruption or things like that, just that the command line script does not run anymore.

Any idea why and where i should look ?


Did you compile and try the project’s test app to see if it still works?

FYI, we use Kaju internally and have multiple users on Win 10 (including my test VM) and have not experienced any issues. Could there be a permissions issue?

Or are you working in 64-bit? If so, Kaju is not handling that properly yet. Since the HTMLViewer works now, I can test it.

Hi Kem, just reached home.

I went into the Test app, i compiled the app and put it on the windows pc and it does not work, it just does the download and does not start the script to replace all , so i can confirm with the test app built does not work.

And the app is only 32 Bit as the 64 still has issues on windows.

So i took the already built in app and run it straight away , does not work, then i build it myself and run it , same , does not work, and all worked ok until i did the latest updates on windows . and i guess something to do with Xojo but i dont think so I assumed that its from the antivirus, i deactivated that completely and still same issue .

Any other ideas ? thanks.

I will try on another system where i did not do the latest update yet to confirm if there it`s working or not .

The only place I can get it to fail is in 64-bit so I’m at a loss. Perhaps someone else has an idea.

FYI, this morning it failed here too so now I have something to examine. Standby.

It turns out that this is not a new problem, but an old one. See the solution here:


Thanks a lot Kem, i will do some tests once i reach home and keep you updated.