Issues with WebImageView (Image Well)

Hi to all,

I am new to Xojo but not to programming. Knowing VB quite well, the language is not a problem.

My problem is with a page containing WebImageView controls. Someone emailed me a Xojo project, and when I run it locally, the images are not displayed. I checked that for each of these controls, Picture under Behavior is correctly set, and Visible is set to ON. No way the pictures are not shown. My default Browser is FireFox, I changed the default Browser to Chrome, same issue. I cleaned bot browsers cache, again the same problem. Rebooted the computer, and… well you guessed.

As a test, I copied the project to another computer - both runs Windows 10 64-bit, ran the project on Chrome and everything is fine. I just can’t figure out what’s wrong. I would like it to work on the the computer where it fails, this is mu development computer, but can’t figure out what’s wrong.

Any suggestions for me ?


On your development PC can you right-click the pictures and choose Show on Disk. That might tell you if the paths are invalidated on that PC.

I’m curious… are the project and the images on a hard drive that’s connected to the machine, or are they on a network share?

@David Cox I checked Show on disk, all the images are in the same directory as the project.

@Greg O’Lone Not on a network share, everything is on a local drive.

Xojo version is 2018 R1, I know 2018 R1.1 has been released but didn’t see anything regarding this issue in the changed log.

I wonder if a setting in the Options may explain the behaviour. One other theory is that the graphic card would behave incorrectly. On my development PC it’s an Inter card, on the other one it’s an NVdia adapter.

Thanks for your suggestions.

I should add on thing: I do not build the app, I run it from the IDE.

[quote=389325:@Gilles Plante]Xojo version is 2018 R1, I know 2018 R1.1 has been released but didn’t see anything regarding this issue in the changed log.
No, but you really should be using 1.1 because there were some other critical fixes in there.

Could you be more specific?

I highly doubt that.

Any chance you could share the project with me so I can take a quick look?

@Greg O’Lone I installed R1.1, still the issue. I copied the prototype from the tower computer to my dev computer, everything works fine but the image appears as a white rectangle. The picture is displayed in a WebCanvas.

In the other project I was sent, images are displayed inside a WebImageView. So it seems the issue is not related to a particular Xojo component. I looked into Windows log to get a clue, didn’t get anything.

Regarding sharing the project, I wait for my client agreement.


@Greg O’Lone I tried to join a file to a private conversation, but just can find how to attach the file.

You need to host the file elsewhere and post the link to the file in your message… Xojo hasn’t installed the attachment plugin for esoTalk, so you can’t just attach files to your message…


All of a sudden, it works now.

This morning I tried something: from my dev computer - where images would not display - I opened the project that’s on the other computer - where images work. Surprise, the images were displayed. Then I copied the project locally, and again it worked.

It looks like the issue has resolved by itself. I don’t like things that mysteriously get fixed, because again they can break :-(.