Issues with TextField Mask

Hi there, we are currently developing a small Linux system based on In this system we are running Xojo GUI apps.

We recently discovered that using the Mask feature of TextFields does not work. If we specify a Mask for a TextField, it is not possible to enter anything into the TextField when the application runs. I can set the cursor in the TextField, but nothing happens when I type letters/numbers on my keyboard. However, if I run the same application on a “standard” Linux system such as Mint or Debian, it works fine, so apparently our embedded system is missing something, but we can not figure out what. We have made sure to fulfill all the requirements specified here:

I found a thread here: that suggests that the Mask feature has some kind of depenceny to the system locale, does anyone know if that is true or has seen this issue on some other system?

Share the used Mask string and maybe (probably) you will get some answers… :wink:

We get the same behavior for any mask string. As soon as the mask string is anything but empty, we can not type anything in the textfield, but just to give two examples of mask strings: “999.9”, “##:##”

Did you try yur project on another machine ? On Windows or MacOS ?

Did you try to export your project (if your license allows that) to save the project to xml or bas ?

Just to be sure the project is not corrupted…

Oh, and what about your SSD / HD ? Is it OK ?

Uhm, for some reason my reply yesterday got lost,…

Running the exact same executable on another Linux system (tried both Mint and Debian) works fine, no issues.
Building the same project for Windows works fine, no issues.

The project is not corrupted, we did several different simple test projects from scratch using TextFields with Masks.
We built them using three different machines and tested on multiple different target systems. The issue reproduced every time when running on our custom Linux installation.

And yes, our SSD:s are fine (in all three machines).

So our custom Linux distribution is missing something that the Mask feature of TextField needs, and whatever this is, it is not listed in the Xojo Linux Requirements, and I am really interested in what it might be,…