Issues with 2015 R3 IDE

After working for two hours with the IDE released today, I ran into these problems (on OS X 10.9.5):

  • No cursor in the editor (it reappears after running the project or after restarting Xojo)
  • At some point no ability to do anything anymore besides playing around with the panels (navigator, search, inspector, etc.). No editing possible and all menu items menu disabled (with the exception of “Hide”, “Hide All”, “Show Others” in the “Xojo” menu).

Fwiw, I’ve been using it all day and haven’t seen any of this. I have also been using the betas for the past few weeks.

I’ve just installed R3 on my MacBook Pro Retina running 10.11 and I have to admit the editor seems laggy when typing. There’s a noticeable delay between every keystroke. Never seen that before on previous releases.

There is also some lagginess on Windows when marking for copying large chunks of code that contains a significant amount of text strings. I am hoping the they make another pass through the IDE and work out some of these UI issues. IMO, the only drawback in a great release.

Some have
Some haven’t
And the cause is apparently not consistent from the process samples that people have posted

That’s frustrating that its difficult to reproduce. As Merv says though, apart from this (somewhat annoying issue) the release is great.

This one is starting to be my top annoyance as I work in the IDE all the time
And I dont see it so its darned hard for me to track down

See: <> - it’s still marked as a beta bug, but now that this has been released, can we mark it as public and hopefully get some better samples from other users to help track down the root cause?

Have never, ever seen it, neither on Mac or Windows.

I suppose that seeing this bug could be somewhat dependent on how fast you type. I’m saying that you type slowly, but I type around 80-90 wpm ( a little slower when coding with symbols and whatnot) and I’ve noticed this problem frequently over the last several years. This latest release it is much more pronounced.

What happens if you open a largish project and just run your fingers over the keyboard to throw a lot of text at it? Do you see any lag then?

If you’d like to see this in action, I made a screencast.

I type extremely fast, after decades in journalism and edition. I have clogged many a word processor keyboard buffer back in the days, and can identify that issue. Never observed it in Xojo since 2013R1.

After seeing the numerous posts about that time and again, I tried many times with the largest projects I could find or create by numerous duplications, same difference.

Thank you. This looks indeed like a clogged keyboard buffer, especially when you show the display letter by letter after you finished typing. I never doubted the reality of the phenomenon, though. Just was not able to reproduce it.

The size of the project does not seem to suffice. There must be something else at work here. A discussion in beta about the issue tended to point to the number of plugins. In your video you mention numerous modules. The grail would really be a project that enables Xojo engineers to see the bug at work, so they can trace its origin.

Heh - I meant "I’m not saying that you type slowly…

I do use the full complement of MBS plugins, and this particular project does have a large number of constants. If I have time tomorrow, I’ll see if I can start with a blank project with no plugins and gradually add in both plugins and constants to see if there is a tipping point where the typing response becomes very slow.

@Norman Palardy - what sort of debug info is most useful? Should I just sample the Xojo process in Activity Monitor when I get the typing to be slow?

You may be mistaking “I dont see it happen” for “I dont believe you”
I do
I’ve seen screen casts, samples, etc
Finding the root cause(s) is not as straightforward as you might think
If it were I’d have fixed it by now

Samples work best BUT you might want to use the cmd line version as trying to trigger a sample using the GUI version then get back to typing in time to sample the slowness can be a challenge
The cmd line one lets you specify a delay - see “man sample” in Terminal

Kimball, have you tried it the Find / Error pane at the bottom showing or closed to see if that has any affect? When we had the problem with slow typing in Windows a couple of years back during one of the betas, that had an affect on the problem. On my computer it seemed to behave better when I had the Find pane closed. They eventually found the issue and fixed it during the beta.

It’s a stretch, I know, but has anyone considered a hardware issue? Maybe there’s some common denominator in keyboards, or the USB connection (hub, extender,…), or BlueTooth that could be contributing to the problem.

This may not be related.

In the past 35 years, I have seen this here and there and notably once: the culprit was the lack of available memory (In pre OS X time area). In that case, the software issued a bip each time th user pressed a key…

I also saw that once and it was a conjonction of many things and some were: the user (me) typed “too fast”, the keyboard had a “typing cache” in the running OS (no more) and probably one or more processes were running (a copy files for example [from a far away file server via a 56k connection ?]).

Also: I do not read the said reports, but did they have the number of running application / installed RAM / OS version in them ?

BTW: I do not had time to fire 2015r3 because I am relocating (30 meters away), and so I forgot to do that, yet.


did you do the usual “tricks” like:

a. shutdown, wait a minute, reboot and run only Xojo ?
b. Reset teh PRAM ? [cmd-alr-P-R]]
c. Reset the “USB controller” (I still forgot its name, sorry / its key combination),
d. Did you run Disk Utilities (via Recover) ? [cmd-shift-R]
e. Boot in No Error mode [Shift key depressed at boot time]
f. Create a test user, download back Xojo, run from there ?


and do a once more when every other tricks have been done ?

Happened again this morning after a bit more than an hour. Up to the previous version I was able to have projects open for weeks without any problems. Will see…

Just done a clean install of R3 and removed all plugins. Still get really slow typing even with a brand new project. Not seeing this behaviour with R2.4.