iOS Test with tcpsocket_ios.xojo

Hello everybody,

I am new to Xojo and therefore in this forum too. I am playing around with an example App, which is included in the installation package of Xojo. It is called “tcpsocket_ios.xojo.binary_project”. To start that application in any simulator I need to configure a default device, but this is not possible, because the appropriate combobox is empty (greyed out). is there a way to get that working ?

My environment:

Xojo 2019 Release 1.1.
Macbook Mojave (latest Release)
Xcode 11.0

Welcome Christian!

I am not sure Xcode 11 is compatible with Xojo 2019r1.1

  1. Download Xcode 10.2.1 from

  2. Go to your apps and rename to

  3. Install Xcode 10.2.1

  4. Quit Xojo

  5. Run Xcode 10.2.1

  6. Open Xojo

Thank you very much for that information. I tried that out - without success. Yesterday I had that option to switch between various iPhone Models. Now it doesn’t. ???

Did you open xcode to install the instruments?

yes - I also got the appropriate Alert for doing that. Starting Xcode now is going without any intervention - just straight.

In the meantime I tried to reinstall Xojo - no change. I am even not be able to start any program, which is not surprising, because there is no simulator device defined. Does anybody have any idea ?