IOS Run Disabled

I have downloaded Xojo version 2017 v2r1 and xCode 8 on a MacBook. When opening a new ios project. the run and build button are disabled. When running xCode for the first time, i did accept the license agreement. So, why dont the button work? It is not the baught version, so i dont expect build to work, but i need to know what is going on as far as run is conserned.

Launch Xcode 8
Locations (tab)

Check that Command Line Tools has Xcode 8.x selected

Thank you very much!

This particular thing comes up so often it seems like poor design to me. There’s no point in disabling a button if it’s not obvious to the user why the button is disabled. It would be better for the IDE to display a message when Run is clicked so the user understands what they need to go ahead and do.

@Jason Tait That is also true.

so this appears to be happening again, and I have the latest XCode 10.0 selected in the command line tools preferences.
I’m guessing this isn’t compatible?
What do I need to do to be able to debug again?

You can’t use Xcode 10 or Mojave right now.

ug… can I manually downgrade?

Xcode? Yes, I believe you can grab the latest 9.x version from the Apple developer downloads section.

The whole OS? I believe so, but if I’m remembering correctly it’s not a fun or short process (wipe install being the only way). I may be wrong on this process, which I’m open to correction on.

I just meant Xcode. I wasn’t sure if I could have multiple generations installed at once. I’ve just been using the auto system updates, so never manually downloaded.


You can have both Xcode 9 and 10 installed at the same time. More information here:

You might need to go to Xcode–> Window_->devices and simulators–>simulators and remove those that don’t relate to the versions of Xcode that you are running. Took me three weeks and a lot of searching on the forum before I could run an iOS project, even though I could compile it. Removing the inappropriate simulators fixed my problem