iOS not working anymore with iOS 16 and macos montery

Is anyone @ xojo actively testing the new Apple releases (iOS 16)?
We are having issues getting things running it looks like apps are being deployed with on-device-debugging but the icon is not visible and the ide tells me it can’t run it (make sure the device is awake…, well it is…)

Something changed and no information is given on what/how/where/when by the error message(s).

The ide messages panel gives:

  • MyApp Ended
  • MyApp Ended
  • MyApp Ended
    Yes 3 times in a row…

It seems there is a new “Developer Mode” for the device, It’s required to turn this on in Settings → Privacy & Security → Developer Mode → Turn On …

2022 R2 Still doesn’t allow to run on newer iOS 16.

Here we go again :frowning:

Yes, unfortunately… i’d expected xojo to have this fixed before the release of the newer iOS since it has a major security fix…

The note on the phone side tells me the code signature integrity could not be verfied somehow.

Last ide messages from terminal before “compilation failed”:

cannot determine CPU speed with hw.cpufrequency
2022-09-14 20:17:49.609 Xojo[3948:77032] ignoring key bindings due to unknown OS version

I’m assuming you’ve downloaded the latest version of Xcode and run it at least once.

1 Like

Make sure you have enabled Developer Mode on the IOS device you are attempting to run on if its run IOS16

1 Like

Installing, running and debugging apps with no problems on iOS 16 on iPhone XR, from Monterey on M1 Mac mini.

Make sure Developer Mode is turned on. Installing iOS 16 turns it off.

No problem running on iOS 16 (latest Xcode beta on lates Ventura beta) Both using Simulator and devices (screenshot from Simulator).

As stated by others, please make sure you have your setup updated/configured properly!

I would also suggest that you check all of your certs and profiles in your Apple Developer account. It’s not uncommon for developers to only renew these things each year when Apple releases new software and since many of these things are only good for a year, they start falling around this time each year.

For instance, I had to check my registered devices and update that list before I was able to run on a device this time.

I am able to debug my app on device with iOS 16 and Monterey. I did briefly experience the same problem you reported where Xojo would copy the app to the device but couldn’t launch it, but that only happened once for me and when I re-ran the app it then copied and ran, repeatedly, without issue.

Done did not change the issue.

Yesterday i updated my device uuid and it worked. Wonder how this has worked previously…
So it was yet again the provisioning file (missing the device udid).

1 Like

In contrast, i’ve closed the case Xojo: Account Login
with a little more info just to note.

Thanks all for the suggestions/answers.