iOS compilation fails with file system error

Suddenly, an iOS project I am working on has started to show a file system error when I try to run it.
Xojo tells me a file system error #105 occurred on “private/var/folders/…TemporaryItems/com-xojo.xojo\-temp181/Base.lproj”. I removed the temporary files I could find and can see that Xojo writes new files into it, so the directory is clearly writable. It is not running which would be the other cause Xojo mentions – the error occurred after updating to macOS 10.12.6, and Simulator is not running.
Other iOS projects do work.

Any ideas what might be causing the error and how to debug it?

Never mind, I could solve it by reverting to an older IDE version, running it there and changing back to the current release.

I ran into this same #105 error this morning, with a small iOS test project, that was working fine yesterday, but not today. Only in my error it was complaining about folder /com-xojo-temp11 each time.

When I looked in the TemporaryItems folder, /com-xojo-temp11 was not there. There were others, but not -temp11.

I don’t have a previous IDE version installed, so after fiddling for awhile, including clearing the TemporaryItems folder and deleting the *, restarting Xojo, etc., I copied-and-pasted another folder in the same TemporaryItems directory (/com-xojo-temp4, in this case) and renamed it to /com-xojo-temp11 and then the project ran fine after, without issue.

Weird, eh?

Oh well, as long as it works now.