iOS app stopped running on iPhone, but still works in simulator.

I have a little custom app (for my own use) that I created with Xojo and yesterday it refused to open. It flashes and then seems to quit, I haven’t changed it in weeks btw.

My iPhone is still running iOS 9, how do I go about debugging this? Is there a hidden console app?

Have you opened the device in Xcode’s device viewer to see if there’s a log file of any sort from it ?

You could try iOSConsole.

I have just tried, it says “No Device Logs”.

Thanks, but with zero logs… This is going be harder than I anticipated.

I deleted the app from the iPhone, wen’t to re-install and then tells me my signing certificate is invalid. Open Xcode, doesn’t give me an options, open KeyChain Access, all but Developer ID are duplicated.

Deleted them all, redownloed certificates, compile and get told no provisional profile installed. Again, Xcode download all. And still no luck.

I really hate Apple at the moment.

Oh boy, Xcode just crashed!

But managed to get a new version on there and it’s running. I’m guessing that when I tried to set-up a machine running Sierra and install certificates on it, that broke everything and must have updated the iPhone also.