iOS app quits on launch

MAC OS 10.12.3; XOJO 2016 r4.1; iOS app

I have an iOS app to which I’ve just made some small cosmetic changes. When I run in the simulator (AND on the iPhone) the app launches and immediately quits.

When I’m in the simulator and this happens, I tap the app icon and then get “cannot connect to debugger” message.

I also noted that the app icon is just the generic icon for an iOS app, not the specific icon I have.

This app has been working for 2 years and the recent changes (correct a couple of spelling errors) was “all” that was done. I started over 3 times to be sure the only changes were the typos.

I’ve worked on this for a few days and no joy. Any assist appreciated.

TIA, Tony

Open up console (press Cmd-/ from the simulator) and paste the crash log from your app here or in a PM and I can try to take a look.

The crash reports of the simulator are located in


I had an app I wrote and never released that is only on my iPhone. It used to work fine, but I think an iOS 10 update broke it. It crashes on launch now and I haven’t taken any time to look into it. I have pretty much let it languish since I’m so busy working on other stuff.

I will watch this thread though in hopes that whatever you come up with solves my problem as well and it will be a quick fix. So I really have nothing useful to add, but I wish you luck. :slight_smile:

Another possibility is that the provisioning profile on your device has expired. If the app was installed more than a year ago this is likely the problem. If not, you can plug in your iPhone and open up the devices window on Xcode to view the crash log. That should allow you to get to the root of the problem if it is not a provisioning profile issue.

The opening view for this app has tabs.

Doing some additional testing I found that if I change the opening view to any other non tabbed view, the app works.

I’ve delete the original opening view, then recreated the opening view with tabs and the app fails.

So at this point any non tabbed view allows the app to work.

But, I would like to get the tabbed view working - any ideas welcome.

Please share the latest iOS crash report from ~/Library/Logs/DiagnosticReports/