IOException, back from a nap !

I did it once again !

I get a IOException, again.

This time, the original file was in the boot… /Documents folder (OS X).

Environment: I worked a bit with Xojo 15r1 / El Capitan .3.

Circumstances: I was working with the StandAlone and a document I was building (a debugging session), then hold it a bit to watch TV for a while (and it happens that I took a nap…).

When I woke up, I resumed the debug session by starting a Save As… and get that IOException.

Since I trapped that Exception, I was able to get a second chance: I used the same Save As… and try to save the data in the Downloads folder (instead of Documents) and it worked fine to my great surprise.

Is one of you meet that (or similar) recently ?

Also: I have an Edit Operations window (for Rows / Columns operations). I used a couple of PushButtons and use Lines Control as Buttons delimiters. The horizontal lines are no more horizontal (!) in the Standalone application, but in diagonal.

A question comes to mind: what do you do before building the stand-alone ?
a. once you are ready to do that,
b. quit all open applications, shutdown the computer, reboot, launch Xojo / project and build the Stand Alone ?

Thanks for your input.

BTW: this afternoon, I will do a debug session on WIndows 8.1 (to change a bit); who knows, maybe it will work better ?

Also: I waste half of my time to check these phantom “bugs” and the other half of my time to make coding. I needed a function (yesterday) that was in this project two or three month ago, but… I changed the interface and do not implement it in this version. So, I seach in a 2.5 months old project, squash one bug, and get that feature who worked fine (and this project version also get the IOException) (but was a bit slow vs the new one…).
In fact, with time, when something went wrong, it was Xojo fault - in my mind -; but most of the time, it was mine. And most of the time, after a power off, wait a minute ot two, the so called but (IOException) vanished.

Did the message property of the Exception say anything? It might give you more insight to the cause of the problem.

Thanks for your answer Greg,

[code]An exception of CLass IOException was not handled. The application must shut down.

Exception Error Number -1407.

This screen shot date from January 15, 2016. I do not really read what it said to me yesterday.

Note: It may be the environment, not Xojo by itself; that is why, I will take time this afternoon to make extensive debug on my WIndows 8.1 laptop (Move the project and images into a SD-Card, and copy that folder into the laptop internal (standard) HD. I do not store anything in the (too small) 64GB internal SSD.

Yes, but the exception itself may have some text in the Message property when this happens.

It’s also possible that the debug session was broken while you were away and conditions were no longer what you thought.

Hi Greg,

thank you for your answer.

What I share was the text inside the dialog.

You were asking the text in the debugger ? Ah! The Message property: I do not saw it/report it, yet: I will add it today.

Xojo was in Code Editor when I was sleeping, no external hard disk to woke up, no connected mouse, no internet (I set the Plane Mode by hand when I’m done with internet)…

Debug session under Windows: awful. I am asking myself how I was able to use that xxx OS in this yyy machine during six weeks in Nov/Dec 2014 (when I was between two MacBook Pro: the broken one and the brand new I use now).

Read my other report on this experience.