Invalid Code Signing Entitlements

I am trying to submit an iOS app to the app store, but Application Loader is giving me the following message:

ERROR ITMS-90164: “Invalid Code Signing Entitlements. The entitlements in your app bundle signature do not match the ones that are contained in the provisioning profile. According to the provisioning profile, the bundle contains a key value that is not allowed: ‘[ “” ]’ for the key ‘keycain-access-groups’ in ‘Payload/’”

The code isn’t doing anything fancy. The only declares I’m using is to find the iOS version number. So I don’t think I should have to provide a different entitlement file than whatever xojo creates. I’ve tried a number of things, but since it take about 15 minutes to compile, hopefully this will be quicker.

Double check that your Bundle Identifier in iOS build settings of your project matches the App ID in the profile from Apple. If you aren’t using a wildcard App ID to make your profiles, you may want to try that and reload them.

If I change the Build:Bundle Identifier in xojo to anything other than what is there, I get a different message. The different message is something to the effect of the CFBundleID does not match any app configured in iTunes Connect.

I have been using the * app id for all of my iOS apps.

OK. Is it specific to this app? If you build a very simple app with no declares and put it through App Loader do you get the same message?

I create a new empty iOS project and gave it the same Bundle ID. I then attempted to upload it with App Loader and got the same error message (along with a bunch of others complaining about missing icons, etc. But those were expected). App Loader did pull down the icon and othe data from iTunes Connect based on the bundle Id, so that part appears to be working.

That’s odd. I’d try regenerating the app ID/profiles as a next step. If you still have an issue, we’ll take it off forum to work through your specific profiles…

So, I created a quick blank app in xcode and tried submitting it. I got a slightly different error message, but this error message said something like the provisioning profile didnt contain an entitlement to the ‘keycain-access-groups’ along with several other missing entitlements. I don’t know how to add entitlements to a profile. So then I went into iTunes connect. Created a new certificate, using the exact same request file as the prior certificate. Then edited the existing distro provisioning profile and told it to use the new cert instead. Downloaded and installed the new cert and provisioning profile. Hit retry on xcode and the profile issue went away. Next I rebuilt the xojo empty test app and the profile issue was gone. So then I rebuilt the actual app and uploaded it. This time app loader gave me a green check mark.