Install Xojo on Raspberry

Is it possible to install Xojo 2015 3 on Raspberry?

I tried RPM:

[code]sudo rpm -i xojo2015r3.rpm
sudo: rpm command not found

sudo apt-get install rpm
sudo rpm -i xojo2015r3.rpm
rpm: RPM should not be used directly install RPM packages,use Alien instead

sudo apt-get install Alien
sudo alien -i xojo2015r3.rpm
xojo2015r3.rpm is for architecture i386 ; the package cannot be built on this system[/code]

I tried also DEB:

sudo bpkg -i xojo2015r3.deb dpkg: error processing the archive xojo2015r3lfcl.deb (--install): the package architecture (i386) does not match that of the system (armhf) There were errors in processing xojo2015r3lfcl.deb

I tried also TGZ extracted folders with double click on Xojo but nothing.

Could somebody help me?

Thank you Roberto


The Xojo IDE is compiled for the i386 architecture. Raspberry Pi uses armhf.

Thank you Frederick.
Does anyone know if there is a draft version of armhf XOJO planned in the future?

I’d think the Pi is too weak to run Xojo on :wink:
Especially in the RAM area.

Perhaps with a Raspberry Pi Cluster (Multi-PI boards) I don’t think that making it should be very difficult.
see for example build a compact 4 node Raspberry-pi-cluster

Like @Greg O’Lone said on this forum a while ago: " It’s Xojo FOR your PI, not Xojo ON your PI."

… let’s hope that the debug will come soon

I’ve been using:

to run x86 linux xojo under raspbian :wink:

Do I even want to know how slow it is ?

You CAN run Xojo up to version 2017r2.1 (32-bit) on the Raspberry Pi 3B+ using Exagear. It’s a little sluggish, but usable. I think the Raspi hardware of the 3B+ has finally grown up enough to warrant looking at native installation. Without the Exagear emulation layer, an ARM-compiled Xojo should run at speed. Then, of course, there’s the question of supporting a 32-bit program in a 64-bit world. Oddly enough, the Raspberry Pi since the 2B v1.2 has been a 64-bit machine, but the Raspberry Pi folks want to ensure compatibility across all models and are sticking with a 32-bit kernel. SUSE does have an officially supported 64-bit OS image for the Raspi 3 (not the 3B+ yet). There are also a couple of open source attempts; Bamarni/Pi64 for the Raspi 3 (again, not the 3B+) and a really nice Gentoo image from Sakaki that can be easily installed by image with Etcher or using PINN (the NOOBS fork).

As for the memory issue, perhaps a ramdisk? I boot directly from a USB m.2 2242 128 Gig SSD which speeds things up a bit.