In App Purchase assistance

Has anyone managed to successfully use IAP in their Xojo based applications?

For the last couple of weeks, I’ve been struggling against failure after failure, I was using the MBS plugin, then tried my own declares and today I’ve even tried Objective-C code…

I can get a list of available products, but when I go to purchase I either get one of the following:

Error 500

Error 503 - Service Not available

No error, the login wind just sits there with a spinning progress wheel (I’ve even left it for half an hour).

I’ve gone through 5 testing accounts today incase they were not set-up correctly or fucked?

All my requests for help over the last few weeks on the ADF have gone un-answered.

Is IAP really so shit that no-on uses it? I’m so fede up with this POS, and the amount of wasted time I’ve spent with demo projects in Xojo and Objective-C.

Oh, and I’ve been using the Apple In-App-Purchase guide, which has gotten me no-where either.

Last time I tried doing code for IAP purchases, all the documentation and sample code were for iOS and not the MAS (even though both are pretty similar)… I am kind of surprised at how tricky Apple has made it considering it is Apple…

I don’t feel like in app purchase is as common on desktop apps as it is in the iOS store.
Have you tried to get it to work natively before porting to Xojo?

I have tried, and one day it worked (using Objective-C), however it doesn’t work today.

It seems like either I’m missing something important or IAP with Mac Apps really is shite!

I’ve just found some stuff about clearing out my previous transaction queue and that didn’t help. If it helps, the last message I receive in the console is below:

8/19/14 12:06:26.637 PM store_helper[554]: -[ISURLOperation _handleReceivedResponse:]: Received headers for

Hmm… re-reading this, I’d like to remove the foul language, but I can’t edit any of my previous posts. I apologize for the digesting use of swear words. I’m going to go to the roof of the building and throw my laptop as far as I can! Then cry, because I can’t afford a new one until I get some money from IAP…

Anything to do with Apple’s online services is so overly complicated, iCloud, GameKit, IAP…

Well, for some people it works with MBS Plugin :slight_smile:

The first thing would be to setup the items for the sample project, get it signed and working.

That’s part of the issue, I couldn’t get it to work with your plugins, so I then tried some declares and in the end wrote Objective-C and still couldn’t get it to work. I haven’t been able to get it to work for the last few weeks, I keep going and doing something else.

The demo apps are signed and Sandboxed.

Like iCloud and GameCenter, I would pay good money for a well-supported, well-documented, tested, standalone plugin for IAP support. YMMV.

The plugin is there. :slight_smile:
And it has only dependencies to CocoaBase plugin.

The difficulty is to setup all the stuff on Apple’s website, get entitlements and app signed.
Also iCloud, the example is there, but this setup is not easy.

For Game Center you can contact Tom Baumgartner who has a working sample, I think.

I’ve made a test with MBS plugins, and it works fine. Gonna made a Tutorial one of this day or maybe for Koblenz

I would gladly give you extra 15 min for a session to demonstrate :slight_smile:

sounds like a great tutorial.

Work fine in sandbox test environment. App recognize purchased inApp at second launch.

[quote=122489:@Christian Schmitz]The plugin is there. :slight_smile:
And it has only dependencies to CocoaBase plugin.

The difficulty is to setup all the stuff on Apple’s website, get entitlements and app signed.
Also iCloud, the example is there, but this setup is not easy.[/quote]
Tried it last year with the MBS plugins and couldn’t get it work. We talked about it and you told me that Apple must have changed something. That’s fine, it happens, but you couldn’t confirm to me that you had got it working. As I had no further time and had to do it in Xcode/Objective-C, where it worked fine. Perhaps it works just fine now. Perhaps iCloud and IAP work fine too but I haven’t the time to play with this stuff.

My point was simply that while a huge plugin works for a lot of people, I’d personally prefer to buy individual areas of functionality, with documentation specific to the functionality I have purchased, extensive examples for that specific functionality and for the developer to keep testing it with every new Apple release.

I’m sorry for the trouble.
The last time I setup things, the plugin did work with the example.
Just the configuration is tricky and it’s easy to make a mistake without getting a clear error.

[quote=122629:@Christian Schmitz]I’m sorry for the trouble.
The last time I setup things, the plugin did work with the example.[/quote]
I’m sure it did but then it stopped working :slight_smile: I checked my emails and you told me “Apple changed the way authorization works.”

Like I said, Apple change this stuff all the time and I haven’t the time to play around and test things for other people. Hence the desire I expressed in the last paragraph of my previous message. Your MBS plugin is a very compelling product that a load of Xojo devs rely on - but it’s not what I’m looking for in these cases.

I’ll check with Valdemar :slight_smile:

If you got it working in Objective-C, I am sure Sam Rowlands will be glad to know, as his OP was about the struggle he went through with MBS, then declares, then Objective C.

The issue I find with plugins, classes and third party tools is that sometimes the developer assumes everybody has as much knowledge as his in the matter, so the documentation is awfully ecliptic and quite difficult to follow for a less versed individual. In this instance, Christian points out how difficult it is to configure. When I buy a solution, I hope the supplier will help me get to the promised result. If that was not the case, I might as well spend the same time researching a declare and not wasting money on an unguaranteed result.

I know how it must be difficult to supply development tools, but often what is missing is just a well written, step by step tutorial, which shows exactly how to obtain the result.