Image from URL odd scaling on HiDPi

Hi all,

I’m having a bit of an annoying problem. First - the app is not designed for HiDPI displays.

I have a webpicture in a project where the image is 61x61 within an overall container that is 250x140.

The webpicture pulls the image from a URL.

On Windows it displays just fine as it should.

On OS X and iPad, it will display the overall container in proportion as it should, the images loaded into the webpicture the first time will initially appear like they should quickly changing to a smaller rendered image. I can’t stop it from scaling to the smaller rendering. I wouldn’t care if the image was a bit blurry on a retina display, I just want it scaled properly based upon the overall layout. If I use a WebImageView with an asset within the app itself it doesn’t show this same issue, only when I let it access the image via URL.

Any thoughts?

Have you tried this in the prerelease version?

Only the current version (2016r4.1) - although my account is flagged for pre-release, I don’t even know where to go to obtain it honestly as my options under the downloads on the right side of the page seems to only show: Current, Extras, Archived Releases. I’d be happy to try it out and see if that resolves my issue if I can access it.


when you log into this forum one of the Channels will be for Pre-Release so click on that and look for the most current Beta/RC


@brian franco : Thank you, I rarely look outside of the targets that I normally use, didn’t even know there was a thread there for pre-release :slight_smile:

@Greg O’Lone : Ok, I just tried the current beta (17r1b8) and am seeing the same situation. The image is not being scaled when the webimageview is pulling from a URL when not set to support HiDPI. It will (depending on the load time) still pop from a large image (scaled properly) to the tiny icon (of what it would look like on HiDPI if I were manually scaling images for HiDPI). Other icons in the app when I am using embedded graphics all work as they should as long as they are not loaded from a URL - loading from URL being a line similar to:

customCell.icon.URL = app.SERVERNAME + “61/” + data.Value(“image”)

Since I don’t know at what point in Xojo’s handling in a webapp it pulls the image from the URL, I don’t know if it’s something in the javascript on the client side or the actual compiled app…

Here’s what I suggest. Make a bug report in Feedback and include a simple sample project which points to one of your images so I can take a look at it. I also suggest that you do this ASAP as we are reaching the end of the 2017r1 cycle and I’d like to get this fixed if we can.

I did figure out how to replicate the issue. If you have a WebImageView that is in a container that is dynamically added to the page at run time, it will not scale the image properly for HiDPI (at least when the image is pulled from a URL). So, when I setup a test project to send in, I created a static WebImageView on the left and added a container with a WebImageView in it on the right, both WebImageViews pointing to the same image. The WebImageView created in the builder works like I would expect. The dynamically added one does not.

I’m downloading the feedback tool to submit the example.