IDE Suddenly Slow

[quote=395767:@Emile Schwarz]Sorry if already asked, but how many Free GB in your boot disk ?

Do you have checked: Power off after quitting all opened applications, Power ON and only run Xojo. What gives ?[/quote]
Around 140 GB free and it is exactly what I did, I restarted the Mac and open it again, start XOJO and opened the project, nothing else. This drives me nuts .

Sorry.

One last question: what about Disk Utilities (the application inApplications/Utilities I think) ? If there is a bad in the hard disk catalog tree, it can detect and eventually repair it.

Sometimes, he said nothing but do something as the trouble (here) stops.

Is this similar to <https://xojo.com/issue/52624>? Did you check where Xojo is meditating?

@Emile Schwarz The current Firefox versions have a major bug: do not clear the Library, it will takes forever to recover: it takes hard disk free space (for what ?), and slow down as hell the whole computer.

Hi Emile,
my Firefox version is: 60.0.1 (64 bit): is this version affected by such bug?
Thank you.

I’m a little confused as to why everyone is getting so detailed about browsers. I thought it was just a known fact that the web layout editor is slow as molasses on HiDPI. It’s been an issue for ever as far as I’m aware, and I deal with it by making smaller WebPages with clever locking so that they expand properly.

Check the Activity Monitor for cpu % and the login items in the preferences…
Best CHECK solution make a new user install xojo and make a test if response better !!

I do not believe that version have the bug.

The current version is 61.0.1 (64 Bits).

I started to notice the bug when I deleted some entries in the Library pane (window).

Click then press the delete key. If you notice a slow down… bad.
Better not delete anything in the Library and wait for a new version. It is more an annoyance than anything else when you are used to clear the Library window.

The entries in the Library window name does not appears and the size / location / date/Hour is displayed in a smallr text size: 8GB of RAM is too small for FireFox and EyeTV (current El Capitan).

MacBooks will do this when they are overheating. KernelProcess will show 500% or more of CPU in activity monitor as the CPU is throttled.

Is it hot there? Have you ever cleaned the dust out since you bought your 2014?

You are right Michael, but not this time.

Another condition is low memory (too many running applications).

BTW: the above descriptions are when running El Capitan.

While running on High Sierra, Firefox works fine (boot on a standard , external HD, not the internal SSD. The internal SSD may have troubles. I have to investigate.

I can concur with this, my little 2015 MacBook went all crappy with playing YouTube video. The whole machine slowly ground to a halt, I rebooted and it worked for a few minutes and then went slow again. Rebooted into Yosemite (as that’s the OS it came with) and after a 5 minutes of watching YouTube a message popped up to say that the machine was getting too hot, I then put a stand underneath it (to increase airflow) and all’s well again.

This silently slowing down Apple devices has to stop, it’s not going to improve their sales in the long run, it’s frustrating to their users and having a huge negative impact on their reputation.

Are you watching them as flash movies? My mothers MacBook Pro used to go bonkers on Youtube because of flash. Enforcing html5 video helped a lot.