IDE Searching error

I would submit a Feedback request, but I can’t (my license expired yesterday)

It seems that in 2016r4.1 (at least under OSX) that if you set the IDE search to “Match Case”, do some searches, and then uncheck “MatchCase”
it STILL matches case, until you RESTART Xojo

I told it to search for "user (yes with a preceding quote, and lower case) AFTER unchecking Matchcase.
it actually didn’t even find all the lowercase versions, restarted Xojo and it found them all (a few hundred in both Upper and lowercase)

An expired license should not prevent you from filing a bug report. Are you getting a specific error message?

That said, I can’t replicate your problem here. Do you have it set to need a Return to trigger the search?

not sure what you mean

  • clicked on find icon at bottom of screen
  • clicked “Match Case” under “gear”
  • did some case senstive searches
  • went back and UNCLICKED “Match Case”
  • searches remained in match case mode “user” would not find “USER”
  • rebooted Xojo
  • search worked properly again

FYI… Feedback has never worked for me… active license or not