IDE Script Compile error

I have worked on this project on Mac mostly and for a long time.

Had to debug a Windows problem and remote debugger won’t connect.

So opened it on Windows.

I keep getting this error popping up over and over.

I can keep hitting OK to get rid of it but it just keeps popping up.

I have not written any scripts for compiling.

Check the Windows build script for stray characters.

FWIW, error #11 is “This method or property does not exist.”

Where do I find the windows build script. I haven’t edited it.

In realstudio they’re on the main project tab. Not sure where Xojo puts them.

Click the disclosure arrow next to a build target in the Navigator to expand and display it’s build steps.

I can’t find it. DOH!

When you say build target… do you mean Windows?
Here is where I’m looking and I don’t see any arrows to expand anything.

Is this the same project? There should be disclosure triangles in front of the platforms for your IDE scripts. Or is the project corrupt?

Yes same project. Maybe it’s because I’m running an old version of the IDE. 2014 r 2.1. I have 2 controls that don’t work in Xojo on releases after that… I am replacing them in the next month and then will climbe the IDE ladder. But I have used this project and this version for 3 years or more and never had this problem. Just cropped up in past week and I have not edited any compiler scripts or build scripts. Don’t even have any scripts that I have added for compiling.

I’ve had the IDE scripts get corrupted 2 times - not recently, however. They should work even in an older version of the IDE. Never seen an IDE script compile issue without IDE scripts.

Which format does your project have?

Sorry can you clarify what format you are referring to??? Do you mean Mac or Windows? If so I am compiling for both but turned Mac off on Windows to see if that would help. It didn’t.

xml, text, binary? If xml or binary one main file or external files. I’m asking because you could have a look at the project file with a text editor for xml or text files to see if there are any IDE scripts.

Create a new empty project in your format. Add an IDE script for windows. Save the thing. Now have a look at the main project file with a text editor to see where the IDE script is referenced. Now check the same for your project.

My project file says it is binary.

If I click File Save As my options are binary, xml or just xojo_project.
Is the last type text? And can we freely save to the different file types?

If so I could save the file as text and see if the problem continues and if so… look at the file with a text editor
and compare it to a new text project file to see if I can spot the problem.

Also I don’t think it’s the project… why?

Because I closed Xojo entirely and started it up again. While on the opening screen
with no project open… I got the same error pop up. DOH!

It’s time to reinstall Xojo on your computer.