IDE - navigator 2015R4

2015R4 - Windows IDE
Seems that the tooltips don’t appear, just flicker, in the Windows IDE, where the OS-version works fine.
Can somebody check as a second opinion ?

I Imagine that you are talking about Xojo tooltips (not you own application tooltips).
Using Windows 10 I only can have a few tooltips on Xojo ID (the same than OSX) but I can not see any difference between the two systems.

@Ramon SASTRE : in the OSX IDE you get a tooltip when you point to an object in the navigator, telling you what the superclass is. For example: point to “Window1” and see the tooltip: “Superclass Window” … In the Windows IDE this tooltip doesn’t appear when I point to for example “Window1”.

Not a big thing, but just curious if I am the only one who found this issue.

And, when I get a runtime error while debugging, I don’t see the tooltip showing the type of exception anymore when I point to the line of code which caused the error. Of course, I can still see it in the debugpane, but the tooltip used to be presented in previous Windows versions of the IDE.

That was removed by design in this release. When I hover over items in the navigator I don’t get a tooltip at all, but haven’t missed it as I use Windows mostly for Dev.

I think it’s handy seeing the superclass-name in a tooltip. And why is it stil there in OSX version of the IDE and not in the Windows version ?
Not a big thing, but since I work with both IDE, I noticed the difference.

The tooltip over the class in the browser & the tooltip that Wayne’s talking about are not the same thing

You should get tooltips when you hover over items in the navigator IF you have those options enabled (Options > Show default in navigator and Options > Show Types in navigator)

The tooltip waynes talking about is the one that showed up in the code editor over a line with an exception
Quite unrelated

Yes I was responding to the post immediately before mine.

And this is my point: it’s not showing up in my Windows IDE R4 as it works well in the OSX version.
In the Windows IDE you see somthing flickering when you point to an object in the navigator, where a tooltip is shown in the OSX IDE. Of course I have checked the option “Show Types in Navigator”
Please try if you have the same behavior.


I just tried with Xojo 2015R4 and experience the same behavior as you.

I tried on Windows 7 and 8.1

I don’t get the flickering - just no tooltips. This is on Windows 10.

I am running Windows 7 as a Parallels 11 virtual machine on a MBP.
And I definitely have a point, since I took the effort to quickly install Windows version 2015R2.2. And in this version it works as expected, while version 2015R4 doesn’t at this point.
Think now I need to create a FeedBack.


I fired up Xojo 2015R 3.1 and the behavior works as expected

Please provide feedback # :slight_smile:

FB = 41926.

Thanks Joost