IDE issue 2016R4 Windows

Make sure all updates for Windows 7 have been applied as Windows 7 needed several updates to support Direct2D and DirectWrite

All applied, at least through the Windows Update mechanism. Are there others that won’t show up there?

Not that I know of - but that isn’t saying much
I’ve never seen this on my Windows 7 VM’s or my real Windows 7 Pro machine

You know the drill - file a report with steps or a project that shows this

Oh and try a different user account on that same machine
Lord knows why but sometimes that works

Thanks Norman.

We may have a handle on this. It turns out to be the combination of Windows 7, the Aero theme, and an HP machine. The simple solution was to turn off Aero, and we can reproduce it consistently on that one machine but no other so we suspect it’s also something that HP installs on their machines.

Can anyone else confirm?

Kem, just out of interest, are you having the issues on controls that you are manipulating using DrawInto?

If not, are you able to upload a simple project that shows the problem along with some screenshots of the problem?

I have a VM that is able to replicate the problem so I can perform some tests.

No, just standard controls. And any simple project will show it, but I used this for my test. I don’t have a screenshot from the problem machine, but the controls mostly wouldn’t draw.

Thanks, did it look like this?

Or what it totally blank/different?

And are we talking about at design time or at run time?

Yes, very much like that. And runtime, don’t know about design as I created the project on my Mac.

Does turning off Aero fix it for you?

I’m actually getting that problem at design time (an issue with DrawInto), I’m not seeing the same thing at runtime.

I’ll have a little tinker and see what I can find.

Thats a tricky one, I’ve not been able to replicate it at runtime. I’ve made a little video here for you here showing a couple of things you can try (I dont know how competent you are with windows so I made a vid, sorry if you know all this already).

Do you have a vm program like vmware fusion?
Are you able to try a build in a windows vm?

If you want, I can give you some legit microsoft links with working windows 7 isos (used for testing IE versions) that you can install on a trial version of vmware fusion, you could then try a build using a native windows IDE to see if that acts any differently on the customers machine.

If you haven’t done so already, it might also be worth asking the user to email you their dxdiag report and putting in a private feedback with xojo with the report added. Failing that try a reinstall of directx (its something to do with that as it worked before they introduced it).

I thank you Julian, but we seem to have “fixed” it by turning off Aero. We can’t reproduce it on any other machine, just the one.

It would be nice to know why its doing it, but if its working and everyone is happy then I agree there’s not much point looking into it any further :slight_smile:

On a native windows 10 machine it looks ok in the ide.

Windows 7 is starting to become a pain in the behind. I have had several users unable to install my app recently. Yet they have service pack 1.

@Michel Bujardet What is the problem they’re having?

The installer installs the app, and it runs into a framework error. I was never able to reproduce the issue.

Of course, my first thought was the C redistributable, but all of them have the version where I install the DLLs.

I don’t suppose it was:

“The program can’t start because api-ms-win-crt-heap-l1-1-0.dll is missing from your computer. Try reinstalling the program to fix this problem.”


“Failed to locate Framework DLL?”

Are there any outstanding optional updates on the machine?

Not now, and as mentioned, turning off Aero fixed it. We have not found the issue on any other machine.