IDE issue 2016R4 Windows


I have upgraded from 2016R3 to 2016R4 and when opening the IDE some of the form’s does’t show alle the controls.
Like captions missing from segmented controls,
I can compile it and it works.

Example 2016R3


I have the impression that the controls are fully transparent.
Bug ?


Can you please test with 2016R4.1 - just released.

Hi Joost, just installed 2016R4.1, problem still exists.

I am seeing the same thing when making a new deploy of our application. The strange thing is that it works correctly for most people, but at least one has the above problem. I am unsure why.

We’re having a similar issue with a single user. We just turned on the HiDPI setting for the app, and he does not have a hi-def monitor.

We had to revert to R3 to make it work for the computer in question. Again, R4 and R4.1 worked for most computers, but not all. Turning HiDPI on or off made no difference.

Is there a Feedback report for this yet?

I’ve mentioned it in other related graphic Feedback cases (2 cases) on Windows. Missing handles, missing lock icons, missing controls, the problems are so omnipresent with the Windows version on every computer or VM I have tried it on. But they say they can’t duplicate it. At some point I just got tired of throwing tens of hours into to trying to find the cause, it’s unusable to me at this point.

See the last entry in FB# 45672. I get many ListBoxes missing and all kinds of weird graphical issues in a project that loads and works perfectly on Windows in 2016r1.1 and earlier.

QUESTION: Peter, on that screen with the problems, when you click on a control do you get the blue resize handles? And if you right-click on a control and lock it, do you get the Lock icons?

I noticed that you have a PagePanel on that screen. If I had to venture a guess, the one common thing I have noticed these type of problems always seem to have a PagePanel on them. In any project without a PagePanel, I don’t really see the issues that I can recall. I mentioned this to Xojo before.

Hi, no I didn’t got the blue resize handles. After some testing I’ve got the most of the visible controls back.

I clicked on the. “hidden” control I knew the location for , then on top in the IDE I click on the icon “order back” to change de z-order
Then I clicked on the left pane on some other control so the form is not visible in the right pane and then I go back to the form. Now the control is back…

When I try to do this with the segmented control, I see the caption in the buttons but when I move the cursor into the form
it hides the caption again.

There are some screens where I might be missing 10 controls. It’s like the IDE is drawing them, runs into a problem, then stops drawing everything.

UPDATE, I think the missing Lock icons and Resize Handles is related to the Einhugur controls issue mentioned elsewhere in these forums. I’ll download the latest ones he just posted and report if that is the issue.

Hi Merv !

Maybe you got a point! I’m using also the Einhugur controls… Date + Time Control and the 2 forms I remember that doesn’t show good in the IDE has those controls…
I’ll follow up this post :slight_smile: tnx anyway !

I can confirm that the missing controls, Lock icons and resize handles under 2016r4 were related to the Einhugur WindowSplitter control. I downloaded and installed the newest release, and all those issues went away. I still have performance issues related to both the IDE and my built app, but that seems to be related the changes in Xojo 2016r4, which hopefully will get better over time. Right now it’s producing code that is much slower than what comes out of 2016 r1.1.


I had the same problem, I update the Einhugur controls and the other controls stop disappear, but now I have another problem. The Datepicker control is not displayed correctly. The control’s art appear in different place that the blue/gray dots and if I move the blue dots , the controls move.
(Screenshot, I do not know how add a picture, so …)

Locks like where are the blue/gray dots it’s where the control is, but transparent, and the art in other place.

I am using Windows 10, xojo 2016r4.1

Ideas ?

Make sure you’re using the latest versions of those controls

I got them yesterday (buy the last version, download, test)

I am trying out the IDE (Free, without a licence, 2016r4.1 in Windows 7 SP1 32 bits) and notice that, if I add a push button, the border doesn’t appear, the blue resize handles appear correctly.

I add the button to the Window without any container control

We are still having this issue on at least one Windows 7 box with 2017r1.1 and still have to compile with 2016r3. Since we don’t use any control plugins, is there a solution?