IDE Frustrations

Selecting code that scrolls off the screen in the editor doesn’t work. Several feedback reports about this or very similar issues are closed as fixed or marked not reproducible.

So I decide to make a sample project. I start a new web project and drag a button onto the window. I double click the button thinking I’ll just add a long line in the action event to check and see if I can reproduce the issue, but to my dismay I don’t have any events. Go to the menu to add an event handler, and no events there.

Frustrated. Does anyone know of open bug reports on these issues I can add some votes to, or should I keep fiddling with this and file new ones.

Save the project and you will be able to add events.

To select long blocks of text, I put the cursor at the beginning with a single click, release the mouse, then scroll down, hold shift and click at the end of the block.

I created my first web app with a button and an action event without saving the project. It works well for me on Mac OS 10.11.4

Note the issue has existed for a while. I found <> from 2009 that was marked fixed in Xojo2015r3.

Unfortunately, it appears it still manifests in 2016R1.

I added that to the case :


I hesitated to create a new case, but obviously this is the same. Possibly a regression.

It seems the problem is not fixed, at least when trying to drag-select, meaning I click and drag to scroll until a place which is currently hidden.

When the selection gets to the bottom of the editor, scroll does not take place, and to quote previous posts, it “stutters” instead.

It manifests at random. The solution is to save the project.

Saving works for adding the event. Is there a bug on this somewhere? I didn’t find one in my short attempt at a search.

I did find this bug about selecting text.

No wonder I’m frustrated, it’s like deja vu. I even wrote pretty much the exact steps in the case that I just finished doing to reproduce this bug again in 2016r1.

What is the proper thing to do with with, file a new bug, comment on the old one. I never have figured out what is the recommended course of action with this.

I added to another previous post the selection stuff. When there is a duplicate, in general it gets merged with a previous one by Xojo engineers.

The missing events is a different issue. It has been here for quite a while. Saving the project does fix it immediately.

And here is a closed bug for the other issue we’re discussing.


[quote=258752:@Kevin Windham]And here is a closed bug for the other issue we’re discussing.


Just add to it as I did for the other. Norman will probably have a look at this thread as well.

Updated both cases. Hopefully these will get squashed soon.

I’ve tied (and tried & tried and tried but I cant replicate the “no event handlers to add” issue)
Neither has anyone else here that’s looked at several of these reports
That leaves it in the category of “cant fix what I cant see or reproduce”


For me it’s very consistent and I run into it all the time.

New Project, type something for the name, hit OK. (My default project these days is web so that’s what I have here.)

Drag a button on the window and double click it.

I just tried this again and same result. This is 2016r1 on 10.11.4.

Maybe when I have time I could set up a VM and try to duplicate it in that. If I can I could send you the VM somehow. I’m not sure what else to try.

On a whim I created a new user on my machine and tried it in that. So the no event handler thing was gone. No issue at all, so there is some other factor. No idea what it might be though.

However on the new user, there was a lot of screen update weirdness as I dragged things around. Lots of flashing and shearing of the image. Looked horrible. Never seen that before. Yet another strange occurrence.

I’ll play around with the test user when I have more time and see if I can figure out what setting or addition to my user account factors in. Might be the black menu bar or one of my menu widgets. I don’t think I have much else additional added to the system.

Just take a screen recording of what you do that makes it occur
I’m finding that often there’s some detail that is in the recording that’s perhaps not mentioned in steps to reproduce that turns out to be important

@Norman Palardy I have experienced this in the past and inevitably it has been because the control I think has focus is not the actual control that has focus. It took a bit of training to ignore the title of the Modal Window and instead focus on the content of the label above the list box - not intuitive!

If you dropped the label “Add Event Handler to…” & updated the title instead it might be more obvious why things aren’t what is expected.

[quote=258802:@Wayne Golding]
If you dropped the label “Add Event Handler to…” & updated the title instead it might be more obvious why things aren’t what is expected.[/quote]

Only works on Windows & Linux as on OS X this is a sheet
Odd no one had reported that discrepancy

until now <>

[quote=258812:@Norman Palardy]Odd no one had reported that discrepancy[/quote]Y’know I never saw this as a discrepancy, just the way Xojo is - OSX focused. It has been that way since 1.0 (Xojo, not cross basic).

Sorry to everyone else, my input was obviously out of step. Good luck with finding a solution.

I checked again to be sure, and it’s not a focus issue. I just can’t guarantee how to reproduce it.

After quitting and relaunching Xojo I can no longer reproduce the issue as before. So there is something that triggers the bug. I tend to leave Xojo running sometimes for days, so it could be any number of things. I’ll try to pay more attention to this and see if I can figure out what triggers it.

Now it is starting to sound something like this

I reported so many that ended with not reproducible or not a bug or… that I stopped the reports; I even stopped to add entries in my “Xojo Bugs” folder.

I even saw Paste of Event not created where I wanted it to be… not going where I wanted it to be …

How many ties did I wrote that “I am feeling insecure while using the Xojo IDE” ?

On the other hand, doing reports (bugs or here) and not getting answer lead me to think the problem comes from me or nobody care. Sad.

BTW: to really get the new Event where you want it, you’d better select the Class (i the Navigator) and left the event where you were adding code:
you are adding code in the DropEvent of Canvas1 and realize that you forget to add the code to active Drag and drop in the Open Event ?
Select in the Navigator the Canvas1 entry and use the Insert Menu to add the Open event and you have many chances to really get the Open Event in Canvas1.

All in all, Xojo (IDE) deserve a real and large debug session with people (not just one gal/guy and by pure hazard) and note all discrepencies / squash the bugs / special features… in order to remove them.

I noted differences on how a MenuEvent name is set or not depending on what you do. Excepted the pure hazard that let me discovers that, I do not know how someone in a real daily work can find that. (the menu handler name in the Name field is set to the current value or stays as its default value [Untitled ?] where you click in the code editor to add code or click in another entry in the Navigator or…

At last, when I stop working on a new feature because it passed all of my checkings and some weeks after it produce strange results in a standard usage, I am starting to think … ask what happens ? Am I starting to be senile or Xojo is entering in the fourth dimention or… :frowning:

I forgot:
OS X 10.11.4
Xojo 2015r1