IDE display artifacts

Suddenly Xojo’s launch window and the IDE’s properties pane are all screwed up looking. It displays black in many places and redraws/refreshes poorly with controls visually “stuttering” and other weirdness. Closing and reopening the inspector sort of clears up the mess, but only sort of; and it returns soon after. What’s the remedy to stop this from happening or at least reset until next time it happens? Haven’t seen it before yesterday, although a colleague has.

Quit and restart. Works for me.

Also, running only Xojo seems to avoid that.

Restart seems to do nothing, but I’ll give the “only Xojo” tip a try. Merci!

Quit Xojo and relaunch is more accurate (what I had in my still dreaming mind).

  • only happens in RB2k17r3, RB2k17r2.1 doesn’t have the problem
  • changing display settings, dimensions, color profile etc in sys prefs does nothing
  • only happens in Xojo, no other apps
  • Emile Schwarz’s forum suggestions to “restart Xojo” and “don’t have any other apps running” both do nothing to alleviate issue
  • for me it affects launch window, properties pane, the about box, and when i am running the debugger, it can begin to creep into the debugging pane too. ick
  • seems like a Xojo issue, not an OS issue, but don’t quote me on that; just my own hunch

So what OS are you running?

How much RAM do you have?

Is your OS 32 or 64 bit?

Is this on a physical machine or a VM like VMWare or Parallels?

High Sierra. 28GB ram. 64 bit. Physical machine.

Oops, of course earlier I meant Xojo2k17r3, not RB. Old habits die hard.

Please file a bug report in Feedback with all this information and a couple of screenshots.

[quote=381367:@Erick Tejkowski]

  • seems like a Xojo issue, not an OS issue, but don’t quote me on that; just my own hunch[/quote]

I have a Windows PC, i7, 32 Gb Ram, GTX660 Video card and also had the same issue. Working with Xojo on windows you have to use to the recurrent Close/Reopen. Maybe some Memory leaks, but, after some hours of work, the IDE becomes unusable, nothing you can do except, close and reopen.

OT but: is the zero key not working on your device?

If not, what is the point of writing 2k17 instead of 2017 beside making it harder to read and comprehend? You’re obviously not saving any keystrokes …

18 years old bad habit ?
(bug of the 2K year ?) :wink:

Back to the original question:

I get “same kind of things” in the Navigation pane (2015r1), never in the properties pane like in the second screen shot.

This happens after many years of Xojo run, and as I earlier wrote, a Xojo Quit and reload is enough.

El Capitan.
Xojo 2015r1.

Markus, Emile is correct.

Responding to OT posts likewise saves me zero (0) keystrokes and forces everyone else to read it. In the future, you can click my name and ask me questions like this directly, instead of wasting everyone else’s time.

Besides, I’m hardly alone in this quirk.

I hope this isn’t premature, but this week’s 10.13.4 update seems like it might have fixed this issue in Xojo! If it returns, I’ll come back and report it, but so far it’s not happening.


Unfortunately, v10.13.16 causes this artifact/redraw issue to return.

Oh that looks nice. You have a preview edition of Xojo for dark mode?

Joking aside. I’ve never seen something similar. Do you use special settings in your macOS? Reduced transparency? More contrast? Anything else? Did you try another user or another computer?

I don’t use anything special. About the only thing “special” is my video card, an old ATI Radeon HD 4870 1024 MB.

Have also reproduced this on a black trash can Mac. AMD FirePro D500 3072 MB stock graphics, GPUFamily1 v3

10.13.3 had the problem, 10.13.4 didn’t. 1013.16 does again. No other apps are affected. Just Xojo.

Graphical glitches with Apps are common in Sierra and High Sierra. Others have guesssd its because they rolled the iOS graphics engine into the Mac, for me personally I think it’s the drivers and Apple’s update system not doing a good enough job.

Somethings not right with the OS, if it works with one bug fix release and then not with the next.