HTTPSSocket 102 Error on Linux but not Windows?

Rather annoyingly my web application which I had working on both my Windows and Linux based NAS box has stopped working properly on Linux.

The fault centres around a HTTPS Socket which is used to fetch data from a web server. This previously worked fine on both platforms but whilst it still works on my Windows machine it now gives a socket 102 error each time on the Linux NAS.

I can’t believe it’s a fault on the web server end as surely it would affect both platforms equally, so I’m beginning to wonder if a recent update to the NAS has done something.

Are there underlying differences in the way Linux and Windows handle the HTTPS Socket that could be causing this or is there another reason for the error? Mis-configuration?

Error 102 simply means that it disconnected.

Problem is it’s disconnecting immediately and not retrieving any data on Linux but works fine in Windows so I can’t work out what’s wrong other than soem change to the OS? I did have it working previously on the NAS so I’m not sure what’s changed

Is this an HTTPSecureSocket or the newer HTTPSocket?

It’s the old framework HTTPSecureSocket

Check your connectionType.
I have found that some services will disconnect unless ConnectionType=SSLSocket.TLSv12

@jim mckay
Thanks, this appears to have cured the issue at least for now

Can’t think why it stopped working on Linux but still worked on Windows though…
Xojo default is TLSv1 which I’m assuming is for all platforms, so maybe Windows was changing the TLS type automatically to make a successful connection?