https or wsdl with a certificate to get mac model from serial number?

Hello forum,

I want to know if it is feasible to send an https request for a wsdl scheme that needs an associated certificate ?
recently apple changes their part system access (names gsx) with such a scheme
I had a program that worked before, it was https and wsdl but without certificate.
is it feasible ( with xojo and preferably no declares) or is it useless to dig into it ?

thanks.

Have you tried setting the CertificateFile property?

Or try our MBS curl plugin where you can pass a certificate file.

I had it used with Apple we service before.

thanks Greg, this should work
anyway I have to ask Apple for a certificate, and so I won’t go any further into it.
it seems you can only get a certificate for a fixed ip server and as I want an app that can run anywhere I will not get that certificate…
this is only to get the mac model from the serial number and the date for end of warranty I’m not sure I need so much security for that simple thing but he !

Jean-Yves With xojo socket Apple WSDL doesn’t work.

Well, I put a lot of work to get the queries working for Valdemar. :slight_smile:

Yes Christian, A lot of time I spent with you. But now, it works for me.

sorry it worked for me until august 2015 where they changed the security level…
it could still work if I had the time to get a certificate it seems.

I develop an access to GSX (the Apple’s service your try to access). And I can tell you that it doesn’t work with the Xojo socket. The only way is the SOAP Kit from Christian, and the modifications that we have done.

do you speak for the actual gsx of for the version before august 2015 ?
I repeat it worked no problem before aug 2015 with xojo https sockets (not with the soap methods)

We had to switch to CURL Plugin to do the transfers with certificate.
The feature of using a client SSL socket is rarely used.

ah, ok I don’t want to tranfert items, I just want to authenticate and get warranty informations on a serial number
so may be it still works ?

With new access mode, we need to use CURL.