HTMLviewer not playing mp4 anymore

Hello,

in my project there is a HTMLViewer which loads an mp4 directly:

me.LoadURL("http://xxx/test.mp4")

it worked with Xojo 2017 but now I compiled it with 2019.1 and it shows nothing, seems it loads but does not play, did some behavior changed to that?

Your test.mp4 is on your web site, right ?

yes, just tested with Xojo 2017, it works with that version but not with 2019.1

I think its because of http instead of https… seems htmlviewer does not load any http sites anymore only https…

is there a workaround, because my site is not https…

What OS and version are you testing on? HTML Viewer relies on the system heavily, so you might be affected by SDK changes.

I notice your url starts with http and is not secure. This does not fly on newer macOS, everything must be https or you have to add a special entitlement to your app. If you are affected by this, the HTML Viewer is not loading the movie. You can use something like LittleSnitch or Charles to detect and monitor network activity.

OS X Mojave, I will now install ssl certificate on that domain and then, I guess, it will work…

Thanks!

ssl installed, now it works with https

Can you please mark this Thread as answered? Maybe you can mark Tim’s reply as “Answer” ? Thank you :slight_smile:

see: https://documentation.xojo.com/topics/communication/internet/using_non-secure_urls_on_macos_and_ios.html