How can I get rid of that focus ring (Part II)

Sorry that I had to start another thread (because the first time I thought I’d solved my problem, but that was an error …)

My problem:

I use a popup menu and when I start the program it shows a focus ring round the popup menu.

You can see what I mean at

I can’t find a possibility to eliminate that ring; the property “UseFocusRing” belongs to canvas, which is not a superclass of Popup menu.

I am working on Mac OSX 10.8.5

That’s weird. I tried that myself and I can’t get the focus ring to display!

I thought maybe you were using Carbon, but it doesn’t show up there, either. I’m not sure what you’re doing differently. I just put a couple popupmenus on a window with some dummy lines and hit Run. No focus ring.

Type -F7 and try again.


Ah, yes. I did not have full keyboard access turned on!

Indeed, that does turn on the focus ring.

Turning it off, however, is easy: just disable the TabStop setting for the popups where you don’t want this. Works like a charm.

Wow - that it was!
Thanks guys for all your tips!