High IDE CPU Usage While Debugging

All of a sudden the Xojo IDE is taking up 95-100% of a CPU while debug running my app. The actual app itself takes up only about 3%. It’s so high that any attempt to edit with the app running results in lots of rainbow wheels

Quitting the app, the IDE goes back to normal.

Anyone else encountered this?

Still using Xojo 2019r1.1 on Mojave. Was previously running the same setup with the same app running fine.

Due to the log window? See feedback://showreport?report_id=55558
Try clicking the Clear button on the log and see if that helps. If so, it’s probably the same bug.

Eureka! That’s it! CPU 99%>1%! :smiley:

I could kiss your Matt Groening beard!

:slight_smile: I’m also still on 2019r1.1, I wonder if this bug exists in later IDEs? It’s still marked as Verified but not fixed.

Yeah, I’d sure like to know!

The “solution” in later releases was to keep only the most recent 1500 entries in the Messages pane.

Well, better than nothing!

On macOS the messages pane was converted to be just a text area so shouldnt be consuming a lot of CPU
Older versions were an html viewer that just could not keep up esp if you really flooded the log with system.debuglog messages
I forget which version that got switched in
Windows & Linux were different as the tricks that made it really fast on macOS dont exist in the same way on Windows & Linux

And there is a preference in the IDE to hide that pane when you start a debug run
Preferences > Debugging > Hide Search/Warnings/Messages pane on run

I always have that enabled and it makes a difference since when that pane is invisible it isnt going to use any CPU
macOS is smart enough to not refresh it when its not visible

Thanks @Norman Palardy! :slight_smile:

2019r1 feedback://showreport?report_id=55628 :frowning: