Help! OSX Mail crashing 10.9.5

yesterday OS X Mail started crashing on a me a few seconds after I open it. Rebooting does not help. I tried googling and tried a bunch of things I found on-line but it;s no help… even using Time Machine to replace my Mail folder from 2 days ago… Does anybody have any idea how I can fix this?

Partial crash log is below

Thanks,

  • karen

Process: Mail [460]
Path: /Applications/Mail.app/Contents/MacOS/Mail
Identifier: com.apple.mail
Version: 7.3 (1878.6)
Build Info: Mail-1878006000000000~1
Code Type: X86-64 (Native)
Parent Process: launchd [146]
Responsible: Mail [460]
User ID: 501

Date/Time: 2015-04-02 19:01:04.709 -0400
OS Version: Mac OS X 10.9.5 (13F1066)
Report Version: 11
Anonymous UUID: 5C838858-319F-717D-E612-2F44259EC716

Crashed Thread: 5 -[MFMessageRouter _routeQueuedMessages] Dispatch queue: NSOperationQueue 0x61800003be00

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
*** Terminating app due to exception while holding database lock ‘NSInvalidArgumentException’, reason: ‘*** -[__NSArrayM insertObject:atIndex:]: object cannot be nil’
abort() called

Application Specific Backtrace 1:
0 CoreFoundation 0x00007fff9180a25c __exceptionPreprocess + 172
1 libobjc.A.dylib 0x00007fff89b22e75 objc_exception_throw + 43
2 CoreFoundation 0x00007fff916cb487 -[__NSArrayM insertObject:atIndex:] + 951
3 Mail 0x00007fff900679f1 -[MFRecoveredMessage spotlightAttributes] + 2904
4 Mail 0x00007fff90065504 +[MFRecoveredMessage spotlightAttributesForBodyData:plistData:] + 132
5 Mail 0x00007fff8ff90f97 +[MFLibrary _sendAttributesToSpotlight:bodyData:plistData:replaceExisting:] + 52
6 Mail 0x00007fff8ff99c9a __215+[MFLibrary insertOrUpdateMessages:withMailbox:fetchBodies:isInitialImport:oldMessagesByNewMessage:remoteIDs:newDocumentIDs:setFlags:clearFlags:messageFlagsForMessages:copyFiles:progressDelegate:updateRowIDs:error:]_block_invoke1010 + 14720
7 Mail 0x00007fff8ffb6e05 +[MFLibrary executeBlock:isWriter:useTransaction:isPrivileged:] + 1328
8 Mail 0x00007fff8ff95800 +[MFLibrary insertOrUpdateMessages:withMailbox:fetchBodies:isInitialImport:oldMessagesByNewMessage:remoteIDs:newDocumentIDs:setFlags:clearFlags:messageFlagsForMessages:copyFiles:progressDelegate:updateRowIDs:error:] + 4493
9 Mail 0x00007fff8ffd299f -[MFLibraryStore appendMessages:unsuccessfulOnes:newMessageIDs:newMessages:newDocumentIDsByOld:flagsToSet:forMove:error:] + 642
10 Mail 0x00007fff9003b6ee -[MFMessageStore appendMessages:unsuccessfulOnes:newMessageIDs:newMessages:flagsToSet:forMove:error:] + 57
11 Mail 0x00007fff9003b722 -[MFMessageStore appendMessages:unsuccessfulOnes:newMessageIDs:newMessages:flagsToSet:forMove:] + 46
12 Mail 0x00007fff9003b74d -[MFMessageStore appendMessages:unsuccessfulOnes:newMessageIDs:newMessages:flagsToSet:] + 37
13 Mail 0x00007fff9003b79b -[MFMessageStore appendMessages:unsuccessfulOnes:newMessageIDs:newMessages:] + 29
14 Mail 0x00007fff9003a81f -[MFMessageStore finishRoutingMessages:routed:] + 353
15 Mail 0x00007fff90029693 -[MFMessageRouter routeQueuedMessages] + 1174
16 CoreFoundation 0x00007fff916f59ac invoking
+ 140
17 CoreFoundation 0x00007fff916f5814 -[NSInvocation invoke] + 308
18 MailCore 0x00007fff8e6967a4 -[MCMonitoredInvocation invoke] + 211
19 MailCore 0x00007fff8e6b9448 -[MCThrowingInvocationOperation main] + 40
20 MailCore 0x00007fff8e65db28 -[_MCInvocationOperation main] + 332
21 Foundation 0x00007fff8a1b5ec1 -[__NSOperationInternal _start:] + 631

I ran into this
Then so did Greg

He pinged me and asked what I did
I logged in to EVERY one of the web mails accounts that I had mail collecting and went through all new messages
Manually
And in my case I found one that had an apparently corrupt / malicious attachment
I deleted it using the web interface for that account & mail has worked flawlessly since

In Greg’s case I believe it was a specific image file that had been attached to an email
Once he deleted that message from his account things went back to working

And FWIW that looks like exactly the same crash

https://discussions.apple.com/thread/6459693?start=0&tstart=0

Thanks Norm, that fixed it!!!

  • Karen

Apparently you need to come to a conference & buy me a beer now :slight_smile:

Yes, same here. I had it several times myself and some of our users as well.

First I unplugged my mac from the network and then I took every account offline. Then I enabled them again, one after the other, and found the one making problems. Then I logged in to the corresponding webmail account and deleted any fishy mail. Like this I could work around it.

Now waiting for a patch either by Apple or on the mailserver, by our hosting provider.