HELP! - New Web App throwing Internal Server Error

I just tries uploading a new app to our web server. I have 5 others running no problem.

This through an Internal Server Error.

The only difference in this app and my other apps is this has a Valentina report in it.

The Apache error log showed nothing, however I did find something in the apport.log. (Don’t know what this is?)

Here are the lines from the log, can anyone decipher this.

ERROR: apport (pid 26990) Mon Oct 27 08:38:26 2014: called for pid 26989, signal 6
ERROR: apport (pid 26990) Mon Oct 27 08:38:26 2014: executable: /var/www/ (command line “/var/www/ --port=9559”)
ERROR: apport (pid 26990) Mon Oct 27 08:38:26 2014: is_closing_session(): no DBUS_SESSION_BUS_ADDRESS in environment
ERROR: apport (pid 26990) Mon Oct 27 08:38:26 2014: apport: report /var/crash/_var_www_aspe.org_htdocs_xo_ManuChapterCEUProvider_ManuChapterCEUProvider.1001.crash already exists and unseen, doing nothing to avoid disk usage DoS



Run the app from the command line using ldd:

ldd ManuChapterCEUProvider

That will tell you if there are any missing dependencies (or incorrect ones).

Here’s what came back: =>  (0xf77bf000) => /lib/i386-linux-gnu/ (0xf77a0000) => /lib/i386-linux-gnu/ (0xf7780000) => /lib/i386-linux-gnu/ (0xf75d0000)
/lib/ (0xf77c0000)

Hm. That looks normal. From that initial log, it looks like you’re getting a bus error.

Do me a favor and check the dates on the items in the Libs folder and make sure they are the same as the modification date on the app itself.

Dates all the same.

Any idea what I can try.

I have already done:

  1. Copied project Removed the Valentina Report
  2. Removed the MySQL
    Then Removed all but the main form, Same thing

I then created a new web project that has one Window, One Label
Ran it, it ran.

OK, I just took th small basic app with one form and one label, and added the Valentina Init calls:

Valentina.Init( … )
Valentina.InitReports("…" )

And the server error happened. If I remove those lines, it runs.

I will get in touch with them.


Problem solved.

This being the first app to use Valentina (reports) on the Web, Turns out I needed to install it on our Linux Box.

I have to say first I had no ides. So I got in touch with the guys at Valentina via Skype. I uploaded a test app to them that showed the problem. This was right before I left for the day. This morning when I came in they asked me a few questions and was able to guide me in installing the library files through ssh.

I can’t say enough about how good their support is. They are truly responsive and have come through with every problem I have thrown at them. If it’s a bug they generally have a fix in a day or two!

My hat is off to Serge and Ruslan of Valentina!

Glad it worked out for you, Richard. You should have your update now as well.

We are running a sale right now on Valentina Server capacity upgrades. You can server reports off of Valentina Server that works with many other db servers like PostgreSQL, MS SQL Server, MySQL…and its own Valentina DB Server. Order a server (new or renew) standalone or a connections update for Valentina Developer Network and we bump up capacity to the next one.