Help me track this down... error opening web app from the internet on mobile devices

The problem : From mobile devices outside my home network my web app is inaccessible. It shows an error message and does not load

link to the error ->

So, to leave it clear. From a desktop computer there’s no problem at all. And if I try to open the webapp from my mobile phone or tablet typing the local ip address (192.168…) it works.

I have no clue… Ideas ?

Firewall port settings?

hey Paul… but if it was a firewall issue… why would another PC be able to connect ?

The error pops up only with mobile devices trying to connect over the internet…

Is your app standalone ? is it set to use port 80 ?

Which browser ?

standalone, port 80, chrome

Is it down right now ? Does not connect with anything.

try again in 2 minutes…

If you’ve changed DNS lately it takes some time till mobile providers know this. So your local Desktop might get the connection while your mobile device won’t.

Tomas… why would xojo spit out an error if it was not connected ?

Actually, I think the connection works… it’s the session itself does not start (when trying to connect from the internet)… at leats it looks like that…

Is “some fatal error” your code ? I would suspect something on the host.

not sure what you mean… or how to track this down… If you are asking me if the string “some fatal error” is anywhere in my code, the answer is “no”…

where should I be looking at ?

Did you connect ? was it from a pc ? mac ? mobile ? was it chrome ? did it work ?

I just tried your site from Mac, from iPad Chrome, and from a Galaxy Android tablet with Chrome, all three connect perfectly.

Your error looks like something on the host, not in Xojo. the “Some fatal error” does not look at first glance like a Xojo error. Typically, unless I am mistaken, I would expect Xojo to name an exception, or to display a JavaScript error box.

so… it’s the connection from my own home with a mobile the only scenario that is throwing the session error ???

(scratching my head)

I can imagine that “some fatal error” is not something that would come out of xojo… but… where does that come from ?

Thanks Michel!

Where is hosted ? On your home computer or on a host ?

BTW I access your site fine from iPhone Chrome as well. The page is too big, but it is there. points to my home computer right now

actually it’s just a domain I chose as a test from

but that is not the cause of the issue as If I directly type the ip address instead of the result is the same

which seems to point the issue to my home computer as the common denominator… (still scratching my head)

now… check this out…

IF the mobile browser tab is loaded is in secret navigation mode (or however it is called) the page loads, and the app works fine…

You may want to access your site not on your home WiFi, but on cellular data. It is possible that being on the same LAN interferes.

The problem with mobile chrome browser that caused all the trouble was the DATA SAVER setting. As soon as it was turned off, everything worked perfect.

I will have to do the same thing on my android tablet…

Thanks for your time and help Michel and everybody!