Hard Disk troubles

macOS told me he cannor repair a 3TB (nearly full of data on 3 partitions).
It tooks forever to mount (one, two, eventually the three) the disks, allows me to see its contents, sometimes copy some file and eject by itself.

SOS Disk (Disk Utils) does not show it to me, but “System Info” (Apple Menu → About → Hard Disk) can display them to me.

Boot SSD:

I tried EasyUS… Wizard, but this application does not detect the eject.

An idea, someone ?

First, do you have a backup of that disk?
Observation: 31 Gigs free on the boot SSD is not much. Can you offload some data to another disk?
MacOS needs some free space. This would be my first shot.

What has the world come to?


Yep, my first computer had 4MB RAM and a 100 MB HDD and it worked great. In all fairness I must say that it wasn’t even remotely capable of doing what my modern Mac can do. All the Mac machine asks for is power and enough RAM and system disk space :slight_smile:

If this was that, the copy of these data would be done since the day it crashed.

This is a 3TB HDD with 3 parts: macOS 1, macOS 2 and macOS 3.
The free room is different; I was able to copy far more data from macOS 3 (TV recordings).

At last, I was able to boot on a < 10MB HD. It was slow, then I made rooms. This is not the problem.

My first computer had a 143KB floppy and 128KB of RAM… It’s name was Apple //c. I recall booting an Apple IIgs via Network on a Shared boot image located 1,000KM (in a Macintosh Server) from my desk (Paris → Marseille). Oh ! That was more than 30 years ago.

At last, I connected that HDD on my M1 MacBook Pro, with the same king of troubles. As an example, the HDD is ejected when I ask to clear the Trash (sometimes I was able to Copy files, not Move them).

What has the world come to?
Cloud mass storage, so when you do not have internet available, you’re in the deep sheet…
But apparently, some people do not have problems with that. Same with Google applications…

Des beaux souvenirs :slight_smile:

Just an idea: mount one partition of that disk at a time (if it can be mounted at all) and try copying the data to a new disk.

To do that, I need to "see” them in Disk Utils (Monterey)…

If the solution was easy, I think (unsure: who knows ?) I already found it.

From M1 (last Monterey):

Where is “macOS 2” ? How can I mount something that is not displayed (just an example screen shot).

Do all partitions show in Disk Utility?


But, they appears here:

Are macOS 1, macOS 2, macOS 3 bootable partitions?

No. Why ?

The disk has an EFI partition.

Not my fault. Worst, it is a MS-DOS FAT32 part…

I do not know why.

Only one of the two T5 (SSDs) is bootable; it’s the one with a Recovery Partition (Recovery HD)… but both have an EFI partition.

+1 :yum:

luckily the 3 partitions seems to be HFS
you can try a recovery app like diskwarrior, it did marvels repairing hfs broken partitions.
and was almost abandonned when apfs came out :frowning:
after that, the only other solution is to use a data recovery app like datarescue
it also works fine but the process can take days (I even needed 3 months to recover one drive…)
and also it is known that 3GB hard drive are more likely to fail

When it ejects by itself, do you hear the disk shutting down (or other kind of noise)?
I’m asking because, if the cause of the sudden ejection is a hardware issue (like a loss of current, if the cord unplugs too easily), you’ll most probably have to fix this first, otherwise each time your disk stops getting feed and turns off, it’ll get damaged further.

1 Like


No noise.

In fact, the LED is OFF, I got three dialog about HD ejection (just like if I pulled the plug without asking the Finder to eject them).

so it can be a drive power supply problem then. is it an external power supply ? try another one with same ratings if possible.

This is (bad) new for me. I have two of them. A friend of mine have a 4GB 2.5" that had a bad block.