Got a feeling I see a big DUH coming with this one

OK … first post to the forums … I’m a licensed Xojo Pro owner and still somewhat new to Xojo (but far from new in programming language and application development experience). I’m learning the way I normally do … read, try, figure out what I did wrong. I’ve run across a problem that must have a simple answer and probably right in front of me (therein lies the potential industrial grade DUH).

I’m working with container controls and just playing around inserting other controls from the library into the container control and then the container control into the main window. I put a label, push button, rectangle, and line control in the container. When I run the program, everything except the line control shows (is visible). I can put a line control inside the window and it works fine … I can add code to a Paint event in the container to draw lines and the lines draw fine … but when I put lines (from the library) statically in the container from the library, they don’t show. I made sure that nothing was “overlapping” the lines placed in the container or in the window into which the container was inserted.

I’ve read the forums for hours now and tried a variety of different things … all of which increased my knowledge through trial & error about a lot of things but did nothing to explain why lines don’t show up in my container. OK, I’ve already queued up the drum roll … Is there an elephant in this room that I’m missing???

Thanks in advance!
… Don

Probably a bug. Which platform? OSX, Windows, Linux?

Thanks for the quick reply, Rick. I’m using Windows 7 platform.

Here’s another little tidbit I noticed … ANY other control I place in the container can be “selected” with the cursor once its been placed in the container … except the lines I inserted (can’t even marquee select them)

The line placement in runtime has a bug. It’s not obeying the relative container position as the other controls.

Need to go. Make a Feedback report . Include my image. :wink:

So, maybe it wasn’t “me” after all???

BTW … as far as “selecting” the lines, I noticed on further attempts that I could select one of the lines I had inserted but not another (wierd, huh?)

Thanks, Rick … I’ll check out how to make that Feedback report (it’ll be my first, obviously) and do so today.

@Don Lyttle can you give me the Feedback case number?

Hey Geoff,

Would love to … but I’m having trouble getting Feedback to work for me too. When I download and install Feedback, it lets me get all the way up to the end (including allowing the attachments) but won’t allow me to submit (the button is disabled). And yes, I did the “search” required before submitting. I also noticed the status of my “edition” in the Feedback application says “Trial” … pretty expensive trial, I’d say, since I paid my $995 on April 29th (according to my Xojo invoice and online license info … which isn’t a “trial” invoice, I’m sure :slight_smile: )

If I had Feedback, I’d report the problem with Feedback as well, if I had Feedback (if you catch my drift) … a modern day version of “if I had some ham, I’d have some ham and eggs, if I had some eggs”.

How can I get this reported properly, Geoff? I’m sure I won’t be the only one impacted.

… Don

I’ve raised the case in your behalf.


Where are you seeing Trial? Is that in the Options window under System Data? That explains why you can’t submit a case.

Much obliged, Eduardo … thanks for the helping hand!

I’m so doggone excited about learning this software (it has real possibilities of filling some of the application niches I run into with my customers) that any help of any kind moves me one step closer.

Seems like a really robust community of support out there.

… Don


“Trial” shows up in the lower right side of the Dashboard window under “My Info”

Hi Don. I just installed Feedback myself on Windows 7 and it’s working for me. I submitted a case to be sure. I have looked at your customer record and I don’t see any issues. You did have two customer records however and I have merged them into one. Try Feedback again and let me know if anything has changed.

Hey Geoff,

I’ll try to uninstall Feedback and then reinstall it and give it a try … let you know in a few minutes.

Thks … Don

Same thing, Geoff after reinstalling Feedback … it just won’t recognize me as a licensed user.

BTW … my Windows 7 is the 64-bit Ultimate version if that is of any relevance.

[quote=14358:@Don Lyttle]Same thing, Geoff after reinstalling Feedback … it just won’t recognize me as a licensed user.

BTW … my Windows 7 is the 64-bit Ultimate version if that is of any relevance.[/quote]
I wonder if that’s it. Mine is 32-bit. That seems like the most obvious difference and Feedback is a 32 bit app. I’ll ask William what he thinks.

I’m on Windows 7 Pro 64 bit & my edition is showing as Enterprise (which should be Pro now).