GCC version on Linux

What GCC version are we supposed to be using now to have all libraries matching Xojo ?

The http://developer.xojo.com/system-requirements hints 4.4.2

GCC 4.4 though won’t even compile the SDK.

We use our own version of Clang 3.6 with libc++ in order to have a modern compiler that deploys back to older versions of Linux.

This is a bug in the SDK.

I maintain a 4.0.5 build on all of my system (have to build it manually) and that is building tools that are working very well from the oldest 2.4.26 all the way through our experimental 4.3 test platform.

I use 4.4.3 on Linux 32-bit and 4.6.3 on Linux 64-bit.

Thanks Joe, I am testing Clang 3.6

Do you also use that on Raspberry ? or just GCC there ?

[quote=241204:@Björn Eiríksson]Thanks Joe, I am testing Clang 3.6

Do you also use that on Raspberry ? or just GCC there ?[/quote]

We use it on the Pi too.