fp_socket error (osx client target linux server)

This code:
fp_query=“http://mywebsite.com/ag3/fingerprint.asp” + MyQuerystring
fp_response = fp_socket.Get( fp_query, 30 )

Running from a Mac and targeting a Windows server worked. The equivalent windows code worked addressing the same (fingerprint.asp) file.

I moved from a Windows Server (asp) to a Linux Server (php) and rewrote the ASP to PHP (fingerprint.php)

The above code gets the following error when XOJO osx targets the new Linux server:
YPE HTML PUBLIC “-//ETF//DTD HTML 2.0//EN”

The PC client, addressing the same PHP file, or a browser on the Mac will get a proper response, but XOJO gets the above error. It doesn’t like the linux server. I put a snippet of code in the PHP target to write a text file. When the request comes from Xojo code, it never triggers the write. So, the request never gets to the php file, it’s eaten by the server. The linux server does not like the XOJO osx http request.

So Window program client:OK, Windows browser: Ok, Mac browser OK, Mac Xojo:: ERROR.

I’m lost and wandering in the dark…please advise

Paul

Some servers will reject any request that doesn’t have a User-Agent header. Try adding one to your request:

fp_query="http://mywebsite.com/ag3/fingerprint.asp" + MyQuerystring
fp_socket.SetRequestHeader("User-Agent", "My Amazing App/1.0")
fp_response = fp_socket.Get( fp_query, 30 )