Font Size is now different when project is running?!

Windows 10. (and Mac)
Just recently the Bahnscrift Condensed looked fine on the LAYOUT, but once it’s running, it is much wider! (doesn’t fit in box I created)
Using version r3.2, but also tried 3.1 and also on my Mac. Not sure what changed !
Created a new project with just 1 Label. Font is Bahnscrift Condensed. When Running, font is wider.
** I also tried setting Font Name, Unit, Size in event OPEN. Same results
Anyone else having this issue?
Didn’t try a different Font yet.


I’ve run into this before with other fonts. That’s why I always set the font and font size in the Inspector rather than leaving it at 0. When it isn’t set, either in code or in the Inspector, the System seems to choose whatever it thinks is right.

I found the Font Bahnschrift is the one with the problem. Others seem to work fine. Maybe I should delete and reinstall that Font on the machine?

I does show up fine on the editing GUI, but once running changes to something else.

Appreciate the reply.


Is it installed only in this application ?

It’s one of the Fonts available in the Inspector.
I tried a new project with just a Label in a Window using this Font and it did the same thing.


That does not means if that font is available for the whole system of if it was only attributed to the Xojo IDE…

In other words:
you can atribute a font for use with ONE application only or to be used with all applications.

How do you pick whether its available for only 1 app or all??


Run another application (say TextEdit in macOS or LibreOffice everywhere): if that one is not available…

You also can fire FontBook on macOS (Linux and Windows names are unknow to me).