Finder starts to be bugged while 3 Xojo apps are running

The strange computer behavior restarted minutes ago.

Things are strange under the Finder:
windows does not displays their title bar as the “active” window,
Unable to use the Finder keyboards shortcuts (beep occurred when keys are depressed),
Click are done some times (not always),

The environment:
same computer as previously (but 8GB): MacBook Pro 2011-11, 7200rpm internal hard disk,
Boot disk have free space: > 30GB (while running)
Maverick installed less than a month ago,
the external HD is also recent (1.5GB, two partitions, Mavericks 10.9.3),
I was working with data stored in that hard disk (external),
Last application MenuBar is displayed when you’re on the Finder (cmd-tab)
three xojo created applications, (build Xojo 2013r3, other versions unknown)
OS X Mavericks 10.9.4

With AppleScript Editor:
tell application “Finder” to quit

then a click in the Finder entry in the Dock squash the bug(s)
[I also quit (before running the script) GIMP, two of two of three Xojo applications.

Two Xojo applications are multimedia applications; the two do nearly the same thing, but were not created with the same Xojo nor the same source code.
The third application deals with RTF; I created it because I was not able to generate rtf files that works with the two other Xojo applications with Apple’s TextEdit (“pure” Xojo RTF code, no declare used).

After the previous experiences with these malfunctions, I was sure they appeard because of the Xojo (Real Studio) running applications. That was the very same applications and running under Mt. Lion (or was it Lion ?).

The other malfunction was the mouse click who sometimes were inactive. This also appeared earlier today, but I did not noticed (take it seriously) it as serious malfunction.

At the time, someone (one person at least) told he got the same behavior.

I will let things like that for this evening, probably tomorrow, but I will search the projects and built the three application with Xojo 2014r2, just in case this matters.

BTW: the most recent Xojo built application was running, not I do not use it when the bad behavior appeared. rtf in that application (used only to display the rtf file created with the other Xojo application or not) have the MacLib Declare stuff to read the rtf files (unlike the other Xojo application that I was running and really using (read images, read write taw text files).

I used GIMP to import pdf that holds images to master them, save the results as png. That png file was resized using Preview (better results that the use of one Xojo created application). The resulted files are used to create custom icons (set to folders using copy / paste) and images loaded in the two other Xojo applications.

I nearly forgot: Spotlight index are rebuilding for an external hard disk for the whole afternoon (still 8 minutes to go).

The questions are:

do you use one or more (usually more) than one Xojo application at the same time ?
do you get this kind of troubles with Xojo applications running ?

When I wrote Xojo applications, I do not mean Xojo IDE or project running a project in the IDE. I mean Xojo standalone applications.

At last, I am quite sure that I do not run all these three applicatons together since a long time (probably since the last time I had this trouble).


PS: after a good night sleeping, I just had a question to myself: are the two Xojo applications with the similar feature set share also their creator types ? No, they don’t.

The share the “same” name:
The Completist
The Completist Reader

Have you checked your RAM? I was having some random glitches and turned out to be a failing memory stick. I pulled the bad RAM and everything is running much more smoothly now even on half the memory. Never had a problem running multiple Xojo or RealStudio apps at the same time (even big memory consumers for days on end).

Hi Jim,

thank you for your answer.

I just changed from 2x2GB to 2x4GB, some days ago. The trouble appears only yesterday. It stopped when I quit / re-run the Finder. Virtual Memory was on by something (I do not recall).

I will set the same situation this afternoon to see if the troubles come back.

BTW: I set WiFi off before shutting down the MacBook Pro. Back home, I powered it on and contoinue to use from around 13:30 (afternoon) 'till around 23:00 when the troubles were coming.

I was also thinking the trouble may comes from me while programming one of the three Xojo applications (or the three).

I may have done something that create troubles in the Finder.

Everything can happens !

Hi Emile,

Are you using Drag and Drop from Finder to your apps? I’ve found that long DropObject methods can cause Finder to start acting up because the Xojo app is holding the connection to Finder for too long.

By changing the DropObject events to fire a timer as many have discussed solved the issue because the DropObject event (where the Finder connection is held open) completely almost immediately.

I don’t know if this is what you’re running into, but as an example in the theListbox.DropObject:

ReDim StrA_DroppedObject(-1) If obj.TextAvailable Then // drag and drop from the upper listbox StrA_DroppedObject = Split(ReplaceLineEndings(obj.Text, EndOfLine), EndOfLine) ElseIf obj.FolderItemAvailable Then // drag and drop from Finder Do StrA_DroppedObject.Append ConvertEncoding(obj.FolderItem.POSIXPath, Encodings.UTF8) Loop Until Not obj.NextItem End If tmAdvancedBackupDrop.Mode = 1 // fire the timer
In the tmAdvancedBackupDrop timer, I place the code that manages the dropped items. This releases the connection between the Xojo app and Finder.

Tim’s entirely correct here. Finder, by way of the drag manager, is waiting synchronously on your application to complete its work and get out of the DropObject event. You should minimize the amount of work done or delay it until after DropObject returns.

Tim, Joe,

Yes, I use Finder folder drop into ListBox. In the many years of use of the compiled program (and running it in the IDE), I never had this kind of troubles.

The dropped folder contents is scanned and all its Child folders that met criterias have their name (and FolderItem reference) added in the ListBox.

On another front: I tried yesterday afternoon ('till midnight) to reproduce the problem and I failed (but I finished, more or less the work I started the day before).

In other words: I failed to reproduce the bug(s) in the Finder. I was easily crashed (consistently) the load of one rtf; it certainly is large, with tables, etc. I do not have worries about that. I do not recall the rtf fle I used earlier.

In the mean time (before this will happens once again, eventually), I will recompile with the current Xojo (2014r2), just in case it matters.

Hi Emile,

[quote=111981:@Emile Schwarz]In other words: I failed to reproduce the bug(s) in the Finder. I was easily crashed (consistently) the load of one rtf; it certainly is large, with tables, etc. I do not have worries about that. I do not recall the rtf fle I used earlier.

In the mean time (before this will happens once again, eventually), I will recompile with the current Xojo (2014r2), just in case it matters.[/quote]
This is exactly what can cause the problem. Take a few moments and move your DropObject processing into a method and then call that method with a timer as described above and the problem will go away forever.

I also didn’t see it in older RS versions or on older OS X, but the newer OS X versions (10.7+) are very prone to the issue regardless of the RS / Xojo version used to build.